No clue on how to set up Glyphs Viewer

It says to double-click to install the plugin. But the inside the .zip file there’s a simple folder. Since you can’t “double click it to install”, I put it into Library\Application Support\Glyphs\Plugins folder. Not sure if that changes anything.

Then I launched the app, but it says that Glyphs have to running on the same network. Same Wi-Fi network? Because my computer is connected with an Ethernet cable.

So confused.

The folder should have a .glyphsplugin suffix, and as such, be recognized by the system as plugin. Which version of the app do you have installed?

Same wifi network, yes. AFAIK, you cannot hookup iOS devices to the Ethernet.

I’m experiencing this as well. un-zipping the plugin creates a folder with a .gyphsplugin suffix. I’m running the latest version from Mac App store, which is 1.3.19 (485).

You will have to wait for the imminent update of the AppStore version. Version 1.3.19 is not compatible with the iOS Viewer.

easy answer. thanks!

hi mekkablue,

experiencing exactly the same problems,.
i only get a folder which stays where is is (in the ‘downloads’ folder).

and secondly, working with regular desktop computer, being in the ‘same network’ is not possible.

maybe write about this network constraint in your blog.

Correct me if I am wrong, but I believe you have the AppStore version too, right?

Same network: depends on the network set-up. Any Mac with WiFi can act as a host. Should also be possible with a WiFi bridge, but I haven’t tried that.

Ok, I’m having trouble getting glyphs viewer to work as well…I’m using the most updated version of Glyphs (1.4.3), had no trouble installing the plugin, and both my laptop and iPhone are on the same wifi network. But still, glyphs viewer tells me “Please run in the same network.” Anyone got a fix to this issue?

Uninstall the plugin please, and restart. It is built into the latest versions.


I have the problem, that i have the glyphs viewer on my ipad, and downloaded the plugin too, but my ipad can’t see my mac. Both devices using the same wifi network. Any clue?

You do not need the plugin anymore, please remove it again: Choose Script > Open Script Folder, and in the Finder window that follows, delete the GlyphsPreviewServer.glyphsPlugin from the Plugins subfolder. Then, restart Glyphs.

The functionality is built into Glyphs directly now. I will fix the blog entry.

Just make sure you have the latest version of Glyphs (1.4.3 or 1.4.4 beta), and Glyphs > Preferences > Sharing > Enable external preview is on.

Ok, i removed it, but nothing changed. I’ve installed it on my mac, and the app again on ipad, but the ipad still can’t see my mac. Of course i’ve enabled the external preview too. Maybe i have to change some preferences on my router?

It will not work with every network setup, that is all I can say from experience. If you can experiment and report back about a setting for your router brand, it may be very helpful for someone else.

It is a TP-Link WR841ND.

Have you read this:

Thanks, now it works nice.

What exactly did you do? Perhaps I can add it to the blog post.

I have glyphs viewer on my iPhone working great but can’t get it to connect with my iPad. They are both on the same network. Any thoughts?

I didn’t do anything, I was using it at home, with another wifi router, and worked nice, and one day after the glyphs viewer worked in the office too witgout changing the router preferences.

Perhaps one of the recent minor iOS updates helped.