No ligatures after export

I do have to add sometimes glyphs in existing fonts. These OTFs do have a lot of ligatures.
After opening and duplicating the font in Glyphs the ligatures are listed in Feature as »dlig«. After exporting the font they won’t work.
Then I changed the ligatures to .liga, all listed okay in Feature. A new export and it won’t work too.

Tried this with different fonts, no one works…

Please help!

(OS 10.9, FontExplorer 4.02, InDesign 8.02 {CS6})

instead of adding the .liga suffix, you could copy the feature code from the dlig feature to the liga feature (uncheck automatic).

How did you install the font?
Did you read this:

Tried and it won’t work.

Also saved into /Library/Application Support/Adobe/Fonts/ &
into the InDesign program font folder doesn’t work either.

Font installation with FontExplorer works perfect!

You are testing the font with Font Explorer? I guess you have built up a font cache problem. Delete all instances of the installed font, then delete caches, and restart your machine. And then, use the Adobe folder to avoid caching issues.

Do the ligatures work in Glyphs?

Read this, please:

I cleaned the font caches of program & system in FontExplorer.
Deactivated all active fonts,
installed the script, restart … …

Installed the font out off Glyphs in ID program font folder.
It doesn’t work.

And in Glyphs they don’t work too. ;o(

Did you compile OT features in File > Font Info > Features and then activate them in the bottom left popup menu in the Edit view?

I think so.
Here are 2 screener.

Strange is that Glyphs says that it has exported the file (to ID/fonts file), but it’s not there. Export to library/fonts file works, then I do have to copy it into ID/fonts file…

Well, the ligatures do work in Glyphs.
Are you exporting into the right folder?
/Library/Application Support/Adobe/Fonts/

Be careful, there are other Library folders around. It is not ~/Library, and not /System/Library/. And the folder must be called Fonts, do not reuse FontsRequired or whatever other folders happen to start with “Fonts” inside the Adobe App Support folder.

And don’t export into Library/Fonts. You only ever place fonts there when they are completely finished, no sooner. Otherwise, you will run into font cache problems again.

Okay, thanks… I used the wrong folder. ;o(

But after trying the same set up on another Mac
• deleting the font
• font cache cleaning
etc pp

I do have the same result.

The original font has ligatures, the one in Glyhs opened and anew exported has none… The ligatures are in Glyphs, they do have the right feature.

Did you restart your Mac after cache cleaning?
Are you testing in InDesign using the Fonts folder?
Did you make sure you renamed the font family name so there is no conflict?
Did you regenerate the features in Font Info before exporting?
Did you activate ligature substitutions in the target set-up?

YES to all above.

The ligature substitutions are in the dlig feature but you only activated the liga feature. So you need to activate OpenType > Discretionary Ligatures or copy the substitutions from the dlig feature into the liga feature.

Note: In German, discretionary ligatures are ‘Bedingte Ligaturen’. As Georg said, you will find them in the OpenType submenu.

If you want automatic feature generation, add a ‘.liga’ suffix to the glyph names. Select all ligatures, press Cmd-Shift-F (=search and replace in glyph names), leave the ‘Find:’ field blank, and put ‘.liga’ into the ‘Replace:’ field. Then refresh features in File > Font Info > Features.

As I read your posts yesterday I just thought »Heureka!«
Just a damn check mark is missing. But no.

I tried both versions.
• copy the dlig feature in liga (uncheck generate automatic) refresh features
• add the .liga, refresh features

No reaction at all.
I think my head is going to explode… ;o)

Could you send us the .glyphs and the .indd file?

It’s via mail on the way…

Could it be that, in InDesign, you are not typing ‘aA, bB, cC’, but rather ‘aa bb cc’ or ‘AA BB CC’?


Yes I did! Sorry! Sorry! SORRY!