Not creating .otf file when exporting

When I try to export my font to a .otf file, it doesn’t create the .otf file, just the folder containing the following files: font.raw, feature, fontinfo, FontMenuNameDB, GlyphOrderandAliaDB, font.pfa, and generateFont.command.

When I open the .command file, here’s what it says:

Last login: Thu Aug 12 18:10:41 on ttys000
…/Users/Jessica/Desktop/PopFizz-Regular/generateFont.command ; exit;
/Users/Jessica/Desktop/PopFizz-Regular/generateFont.command: line 2: makeotf: command not found

[Process completed]

Any ideas? The design is really complex so I’m wondering if the file size is the issue… I appreciate your help!

Can you send me the resulting folder and the .glyphs file?

I have exactly the same issue. I suppose that the “makeotf” command must first be installed in /usr/bin or elsewhere.

No, the “makeotf” is shiped with glyphs.

There was a issue with the paths to the makeotf file.

Thanks Georg, I sent the files via an email from YouSendIt (my Glyphs file was 43MB). Thanks so much for taking a look!

Perhaps this can help you find the issue:

A makeotfexe exec file is locate in the Glyphe package at the following path:
/Applications/ ts/Resources/makeotfexe

When using makeotfexe in the Terminal, using the same command line than the one given in the generateFont.command, the routine stops on a fatal error stating that the -fi option is not recognized.
In the command line, the -fi option is associated to the path to file fontinfo, which is empty.

Removing simply this option solves the issue, almost partially since it implies using the Terminal to work out the process.

Hypothesis: The issue might not be related to a path error but to a unrecognized -fi option, making the routine stop.

Hope this can help,


I tested the command line command and fixed it. It will be in the next update.

The main cause of the font not exporting in the first place was that it was just to big. Too many paths/nodes.

Is this still an issue? (ie: too many paths/nodes)

I am having this happen now, and I’ve only added a few characters, but they do have textures built into them

Of course. CFF fonts cannot be too complex, especially not have too many small curve segments. Either try TTF as export format, or try to simplify your outlines a bit.

Thanks for your help I will try these.

Sure enough, you were right. I was able to export as TTF no problem. The down side is that I’m adding a worn textured effect, so each glyph has a ton of detail. I’m doing the texture effect to vectors in Illustrator and copying them over. I wonder if doing an auto trace on a textured bitmap in Glyphs give a better, more workable outcome.

Happy to take any advice. (half expecting that it may be to “not add texture to a font”. :wink: )

What really brings CFFs (=fonts with .otf suffix) to their knees is many small curve segments. If they are really very small, you might just as well replace them with straight lines:

  • There is a plugin (find it in Window > Plugin Manager) called Retractor that does that.
  • Alternatively, apply the Roughen filter, which creates many small straight lines.
  • from the menus, run Correct path directions, Round Node Coordinates, Remove Overlaps and Tidy Up Paths, which should help clean up your outlines already
  • and perhaps delete the smallest paths with the Delete Small Paths plugin (again, find it in Window > Plugin Manager), anything below 300 square units is probably not worth keeping

I am in the process of preparing a tutorial about this.