Not exporting .otfs of two instances

Hi there, I’m having problems exporting .otf’s of all instances from a Glyphs file.

  • Running on Version 2.6.5 (1342)
  • Font family name is set
  • All instances are set and active
  • Exporting .otfs worked fine until now
  • The font design is pretty simple (not many points or curves), the glyph set is pretty minimal and the file size is not big - 778kb.
  • I have re-installed the app and still the same problem

So the problem is - on export, two .otf files (two of the six instances) are not generated in the set destination folder.
In the Temp folder, the instance folder file appears but has no content - i.e. no generateFont.command to check.
However, it is possible to export all six instances as .ttf files. They appear in the destination and Temp folder as expected. This process also creates a generateFont.command file in the previously empty folders. This file can be run (as per the ‘not exporting’ tutorial instructs) and it creates an .otf file in the folder. However, this file is called font.otf and each glyph set within it is a load of triangles (needless to say this bares no relation to the font design :slight_smile:

Any ideas as to the source of the problem?

Do you get any error message? If not, can you send me the .glyphs file?

No error messages - I’ll send you the file now