.notdef glyph instead of space when printing

Hey guys !
When I print some text using my new font, the space is replaced by the .notdef glyph.
However, my characters seem OK in Glyphs…
Do anyone knows what is the problem ?

(no problem when exporting in PDF, the issue appears only when the document is printed)

Have you read this: https://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Yes, @GeorgSeifert, I have. That’s why I only export my OTF files in the Adobe Folder until the font is totally finished :wink:
But I don’t see my problem in this page talking about font cache

Here is what happens : I export a PDF file using my font. The PDF seems OK.
When I print it, the notdef shows instead of each space character…

  • Is the screenshot from reopening the exported OTF in Glyphs?
  • In which app are you printing?
  • And have you reset your printer memory? If you printed the font before, an old version may still be loaded in the printer RAM. Printing with a different font name may solve this, or resetting the printer.
  • Have you covered the complete Win1252 charset?

So many questions ! :smile:
Thank you for helping me, @mekkablue .

• The screenshot wasn’t from the reopening exported OTF in Glyphs, but I’ve just checked, it is the same.
• I printed the PDF using “Preview” (Mac OS).
• I didn’t reset my printer memory : it was the first time I printed the font.
• I think I don’t cover the whole Win1252 charset : my charest is the one that MyFonts needs, as I did for my previous fonts, and I never had this probem before…

So you mean it was from the .glyphs file directly? Why did you add .null and CR then?

The problem may not lie in your font. But in outdated hardware/printer drivers. You can try making sure you only use ascii in all names. And you can cover win1252 and MacRoman.

I didn’t add .null and CR, they were here when I imported the OTF file initially created with Fontself.

You mean I should delete those 2 glyphs ?
I’ll update my driver printer if there is a new version.
How can I be sure only ascii names are used ?

Is there any way to know what characters I need to make in order to have the win1252 + MacRoman complete charset ?

BTW, is there any “official” font validator which can see the different problems of a font ? (I know the one of MyFonts, but it didn’t tell me there was such a problem with space glyph…)

In font view (Cmd opt 1), in the sidebar, under filters, there are two entries. I have a sight suspicion it is a missing nbspace.

Consider reading the tutorial about opening existing fonts. And perhaps the one about porting to Glyphs.

Hey there !
I can actually see in the sidebar that I only have 208 chars from the 218 Win1252, but how can I know which ones I need to add ?

I have a message for you, @mekkablue :

As you were right about the nbspace char (it’s missing) I created a new glyph duplicating the space one. So Glyphs added “space.001”. But when I try to rename that glyph to “npsace”, the app crashes. (I send the bug via the pop-up at re-opening the app)

Last question : do I have to delete the .null and CR chars in my master ?

Thanks !

Simply Right-click on the 208/218 numbers to get a pop-up showing the missing glyphs. Then, you can select and add them.

Thanks @composerjk !

The .notdef char is back ! :scream:
I don’t understand… I export a PDF file then printed it.
I completed the Win1252 charset, thanks to @composerjk.
But I still can’t create a nbspace char because of the crash when I duplicate the space glyph and trying to rename it…
What can I do ?

Try this:

  1. Don’t duplicate the space character; instead…
  2. Add a New Glyph and name it nbspace.
  3. Set its width to match the space character.

Thanks @George_Thomas it works !

I now understand why sometimes the .notdef char appears and sometimes not :

When I print from an app, the space char is OK.
If I print the same file from the PDF viewer of Gmail, the .notdef char is back !

Do I have to worry about that, or can I consider it is not a problem ?

I’m not familiar with Gmail’s PDF viewer so don’t know where the fault lies, but I would not want the character showing when using my fonts. The fact that it works from other apps is a good thing though.

Can you try printing from an Adobe app?

Then you can use the Adobe Fonts folder:

Can you post a screen recording of how you change the name? Is somehow UI related and I need to see what exactly you are doing.

@GeorgSeifert I tried to record the renaming bug, but now it works ! (Perhaps because I installed the v3044 yesterday ?)
But as I said, thanks to @George_Thomas, the nbspace problem was already solved.

@mekkablue I made different tests, and managed to isolate the problem :
• .indd printed from InDesign : OK
• .pdf printed file from Preview : OK
• .pdf printed from Safari : OK
• .pdf printed from Chrome : OK
• .pdf printed from Firefox : WRONG .notdef instead the space chars !

So the .notdef problem lies in the Firefox PDF Viewer.
I installed the last version (84.0) but that doesn’t change anything…

Do you think I have to worry about it ? (the strange thing is that if I print any other font in a PDF from Firefow, those notdef chars don’t show…)

Just wondering - i assume all other pdfs printing just fine, no weird behaviour? Have you tried using the font when it was just out of Fontself (before you opened it in Glyphs) in a pdf and then print?

Very good idea, @elena !
I’ve just tried to print a PDF file with the OTF font from Fontself, and the .notdef chars appear ! (with the Firefox PDF viewer)
So Glyphs is not guilty :smiley:
But I still don’t understand where this could come from…