Off axis master breaks the font

I have a variable font with weight and width axes. Started with four masters at these positions:

  • wt:100 wg:100
  • wt:100 wg:900
  • wt:900 wg:100
  • wt:900 wg:900

With this no problems at all, everything works fine. But when I add a fifth master to wt:700 wg: 300, suddenly the exported font doesn’t work. Only the fifth master is accessible and even then the font displays in Indesign at a wrong size with a wrong leading. In Glyphs and in Mark’s Variable Font Preview it works fine. Glyphs version 3.0.4 (3108). Tested also with Glyphs 2.6.7 (1357).

Glyphs 2 doesn’t support intermediate masters, you need Glyphs 3 for that.

Like mentioned, I used Glyphs version 3.0.4 (3108) first.

Sorry. I just saw the reference to version 2 and didn’t read the rest.

Is the new master at the end of the master list?

No worries. The masters are in order from narrow to wide, so this new master is right in the middle of the list.

Can you send me the file?

Sure, just sent it to support.

You can’t set the off axis master as the default master/Font Origin.

That’s inconvenient, but ok. I now changed it to master at 100, 100. The font still doesn’t export properly. In Indesign all other masters look good but this fifth master suddenly flips upside down and outside the text container.

When I pick the (100, 100, Thin Condensed) master it works fine, only if I pick any of the other masters, then it doesn’t work. I’ll have a look.

This is how Indesign displays the Regular (at 300, 700). All other instances show up fine.

I have already meet this problem.
A solution is to add a master with :

  • wt:100 wg: 300

You need to keep the same structure if you want an correct interpolation.
Actually you have :

wt:100 wg:100 -> wt:100 wg:900
wt:700 wg:300
wt:900 wg:100 -> wt:100 wg:900

But Glyphs need this to do correct interpolation :

wt:100 wg:100 -> wt:100 wg:900
wt:100 wg:300 -> wt:700 wg:300
wt:900 wg:100 -> wt:100 wg:900

It should work with only the five masters you had in the file you send me. Just make sure to select the “Thin Condensed” in the “Variable Font Origin” settings.

@HugoJ That was needed in Glyphs 2, Glyphs 3 can handle one middle master like the 300/700 master.

1 Like

I already did. That screenshot above was taken after this change. The exported font doesn’t still function properly.

@trebe Can you send me the .glyphs file in the current state and the exported .otf file.

Thanks HugoJ. I hope this is not the only solution, seems like excessive work to add masters just for master’s sake.

@GeorgSeifert Sorry my mistake, I had selected the master at 100, 900 as the origin. Selecting 100, 100 as the origin fixes the problem.

Now my question is, am I locked in forever to keep the origin at 100, 100? Why can’t it be some other master?

The code that deals with the middle master has a bug. I’ll fix this eventually. Only the middle master will never be possible. Unless you add a lot extra masters (four in this case).