Offset curve issues

I’m recently working on a monoline font with offset curve parameters set as instance filters.
Two problems occur in my case:

  1. The corners are flat, not square – as described in that topic: Monoline Font: Extending Strokes with Offset Curve or other feature?

  2. Serifs and horizontal lines are set under the baseline and over the caps height although I enabled Auto Stroke.

The screenshot of my Instances window shows two filter lines. The first one is with Auto Stroke checked, the second one with Auto Stroke unchecked. But both lines show exactly the same values, so maybe this is the reason for not fitting into the vertical metrics.

Help would be very much appreciated!

What do you think about some improvements of the Offset Curve filter? Some advanced options as corner behaviour would be great!

Thank you and best wishes

The corner problem is fixed on the upcoming beta version

You can try the Auto Stroke setting. (It will produce a much better result in the next version.)

Thank you, men!

Hi, thanks again for your advice. How can I enter the Auto Stroke settings?

With the recent Beta (2.5b) the corners are almost fixed (except those where start and end points meet in open paths), but the issue with the unwanted overshoots still persists.

And is there a chance to fix the ending behaviour of diagonals? By default it is 90°, but it would be great to choose vertical or horizontal stroke ends.
Is it best to finish the design as far as possible in the monoline file and afterwards generate new files with offset curves and amend those issues by hand?

Best wishes

With the Auto Stroke setting, the overshot should be fixed. To get the correct Filter parameter, you can use the gear button in the Offset Paths filter dialog.

Dear Georg,
I misunderstood “Auto Stroke settings” by some possibility of customizing Auto Stroke somehow.
In my Offset Path settings Auto Stroke is set active, but horizontals are still overshot.
The Filter settings in Custom Parameters shows the following text:
Filter = “OffsetCurve;10;10;1;0.5;”;
Did I do anything wrong?
Best, Ekke

I just tried it and the filter sting is not correct. You need to replace the 0.5 with auto. I’ll fix this.

Thank you, Georg. Meanwhile I will amend that in the copy text.