Offset curve weird behavior



Correcting a couple of diacritics, the vectors acquired curves and corners. This is a monoline font! it appears with >show interpolations and is applied when >offset curve is applied.

I have not changed the parameters and can’t get rid of this “effects” they happen in old files, different computers.

Any idea why is this happening?


What version do you have?


Hey Georg

I have 2.4.3 (1064) macOS Sierra and High Sierra


Hello @GeorgSeifert it would be very useful to know if this is a known bug or I have messed in the setup.

The monoline vector appears with “features” that show both in the offset curve preview and when the filter is applied.


Can you send me the file?


How do you get the preview? With the ShowInterpolations plug-in?
If so, what do your instances look like, especially the custom parameters?


Hello @mekkablue, yes this preview was done with > Showinterpolations, there are five weights. The parameters are just offset curve and round corners


Can you try updating to the latest cutting edge version and see if the problem persists?


Just updated to Version 2.4.4 (1075) and it is still happening.


In 2.4.4, the result is this:

But this is fixed in 2.5 already:

You will need to update to 2.5 or downgrade to an older version of 2.4.


Thank you @mekkablue downloaded Version 2.5b (1076) and it looks like it is working.


How do you get this rounded end of strokes in the preview of a monoline font with the Offset Curve filter?
I’m trying to the same result, but somehow the Rounded Corners filter has no effect on my preview.


Glyphs Version 2.5b (1092) Offset curve + round corners filters are working OK


How do you get this effect? Is it a custom parameter in your master or instance?
Would you like to show me what the custom parameter look like?



This is achieved via custom parameter. You list offset curve first and then round corners or rounded font later.


Maybe I’m doing something wrong, but I’m not seeing the Offset Curve preview when I’m using custom parameters in my instance.

In the screenshot is how I set things up. Is that the correct way of doing it?


Yes. You are doing something wrong. You don’t need the <> in the filter string. Just: OffsetCurve;50;45;1; And you need the 1 at third position.

The easiest to get this right is to use the Offset Curve Filter, set it up as needed and then use the gear button to copy the correct filter string to the clipboard. Then click in the custom parameter list and paste.


Ah thanks Georg, I’m not used working woth custom parameters.

It works now, but only for the vertical strokes. The crossbar of the H does not show in the preview.


Any reason why the crossbar is a closed path?


Ah yes, sorry the path was closed indeed…
It’s working now. Is there a method to make the endings of diagonal strokes follow a strait baseline like with the A?
And the apex of the A is not completely vertical in the preview. How does that work?