One language for all Reporters in the Palette sidebar


Is there a way to have all the Reporters in the Palette sidebar in the same language? Pref English please.
Now I have Dutch, German and English mixed together. Since I do type design in English, I find it hard to ‘see’ the option I’m looking for because of all the different languages.

And a sort option would be really great. Having my most used filters at the top would be a huge timesaver.


That depends on the plugins and the language setting of your system. You might try to check the “Disable Localisation” in Preferences.

Hi Georg, Disable Localization is off.

Actually all the plugins I downloaden were in English, but still it uses 3 languages in Glyphs. Does it look for the country I’m in when installing the plugin?

Also, I see you got some names with an asterisk in the name. Those are very old versions. Please remove them manually from the plugin folder and reinstall via the plugin manager. Otherwise those exact versions won’t get any updates.

There’s a way to localize the plugin names, but usually I cannot bother to include all languages, so usually I go for english.

I’ve installed the plugins again via the plugin manager. The asterisks are gone, but the naming problems persists.
Well, it is what it is… :wink:

Great! I just wonder, why they don’t appear in alphabetical order, they should. Is your Reporter Toggler also installed via the Plugin Manager?

As I said, If plugin developers provide other names than English is up to their choice. How much this is related to the Disable Localization feature, I don’t know.

What would you prefer? All in English? Or all In dutch? You might need to address each developer to implement your name proposal :slight_smile:

Apparently the Reporter Toggler wasn’t up to date yet! It’s quite hard to find out what is and what isn’t installed via the Plugin Manager. It looks better now.

Concerning the language, I’d prefer English. Since it’s still mixed up I’d wait and see what happens with an update. I can always contact the developer personally. Perhaps they have tips on how to prevent these naming options.


Can you check what languages you have in the System Preferences > Language & Region > Preferred languages?

Just Dutch, my system- and mother language.

That is the problem. There is no English in the list, so it picks the first language that is provided by the plugin. And as the different locals are in a dict, the order is not really defined.

Add English to the list and move it to second place (to keep the rest of the system in Nederlands).

1 Like

Yep, that fixes some of the issues! Cool, I never ever had a second language set up. :wink:

So the rest of the issues must be dependent on the developer. Hopefully they will all switch to English.

Thanks so much!

I suspect if you make English your Primary language they will all appear in English; mine do.

I’ve been thinking about that, but for most things I do it’s easier to use my own language. Since I have this issue only with Glyphs I’ll just leave it as it is.