Open path font export

Hi

I am making a conceptual “font” (yes calling it conceptual not to be judged by the pros) and some of the Glyphs are open paths. While using Glyphs Mini2 the glyphs look all fine but after exporting the open path ones just vanish to emptiness. I have tried both with and without remove overlapping but nothing seems to be working.

Is there anything I can do about it or is that stupid idea that was forbidden by the opentype gods?
Thanks.

1 Like

Fonts can only contain closed paths. You can run the Offset Curve filter with a very small offset to get a similar effect.

thanks for clarifying, I was afraid this was the case. I am designing font that can be used for CNC machines that can execute each font line with single movement. And of course a typeface that you can apply any brush/line thickness.

There are several discussions about that on the forum already. Maybe you look through those?

Thanks for the info and please excuse my ignorance for not using the search function.

So it will work exporting into .ttf but Glyphs Mini does not have TTF support and I just purchased v2 because v1 mini was suffering with unknown makeOTF error. Damn.

I’m waking up this old thread because I’m in a similar situation. For a few years, I’ve been using the old Glyphs mini 1.5 to export open path fonts. This worked really well with the CAD software that I created myself. (Not in any Adobe software, but who cares? :wink:

I guess the removal of open paths on export in Glyphs Mini 2 is an algorithm that runs through the paths and removes open ones during export. Can we please please have a version where we can opt out of this? :pray:t2:

I would really like to continue using Glyphs Mini for our weird edge case :slight_smile:

Can you send me a sample file. The .glyphs and the exported font?

Sure! Where do I send it?

Send it by email to support at this domain.

Done!

I changed it in Glyphs Mini 2. Will be uploading a new version soon.

2 Likes

My god that’s amazing! Thank you for going out of your way to do this! That’s so kind :heart_eyes: can’t wait for the update!

Just tested with the new “cutting edge” version 2.1.6 (117). It works perfectly. Thank you Georg!

1 Like