Opentype features not previewing in G3

The “Features” selection in the bottom left corner of the window has a red exclamation point warning next to it, but when I open the Features tab in Font Info, I don’t see any errors. The Languagesystems and Features files are all being generated automatically. I’ve tried updating and compiling many times. The features work fine in export.

I’m totally new to Glyphs and type design, so I apologize if this is an obvious problem. I’ve tried searching the forum and docs, and don’t see anything that appears applicable.

1 Like
  1. Does it stay like that after closing and reopening the file?
  2. Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

I have the same exact problem, tried to restart it and just updated to latest beta version and still hasn’t changed.

Same here, tested in 2 different setups.

I’ve tried quitting and relaunching Glyphs, and I’m on the beta already.

same here (latest beta)
Screenshot 2020-12-21 at 17.25.50
Relaunching Glyphs doesn’t help. Export works fine (all features work).

Same here. Even when creating a new file and adding a single feature with a single rule:
Test.glyphs (6.0 KB)

Glyphs 3.0.2 (3046)

Same here.

After some back and forth, I‘ve narrowed it down to the LOCL feature most probably causing it (at least for me). Disabling the export of glyphs present in that feature (Tcedilla, Scedilla et c) made the Features preview work again.

I fixed it.


Thanks for the swift fix! Is there a way to download the fixed version? When I check for updates (with “cutting edge” checked) I don’t get a new version (current: 3046).

I’ll prepare a new version tomorrow.


The problem persists in [3047], with this file in particular.

A side question but also connected to previewing – The “Text Preview” panel (which is a great feature, thank you) seems not to be influenced by the main app preview at the bottom and features that are turned on/off. Will it be possible to include some settings bar for the Text Preview window like in the case of “TextPreview App”?

It works for me:

I’ll have a look at the text preview panel. Good idea.

1 Like