OTVar Player Script / Back and forth doesn't work

I’ve installed (and updated) the OTVar Player Script —thanks Rainer!— and it’s very useful. But the “Back and forth” option doesn’t work for me. Do you have any clue?
All the best,

Works for me as expected in Glyphs Version 2.4.2 (1056) on macOS 10.12.6 (16G29). Please make sure you have the latest version of the script.

Damn. On Glyphs 2.4.2 (1056) and MacOS 10.12.1, and the latest version of the script, it doesn’t work for me.

This could be the reason. Please update your OS and try again.

Unfortunately not, I updated to 10.12.6 but still doesn’t work. I tried to click on the “earth” emoji first, while or after the animation and it’s stil going forth, never back.

The earth emoji just creates an HTML file. Expand the window a little to show the option for going back and forth.

Ooh yes. How silly I am

BTW, what does this HTML file? Where is ti saved?

Where you last exported a variable font.

I’m using latest version. When I run the script, it alway switch to show regular master only. Any suggestion please?

What do you want to use it for? If you want an interpolation preview that works with multiple masters, maybe try this (confirmed to work on Glyphs 3): glyphs-scripts/InterpolationPreview.py at master · eweracs/glyphs-scripts · GitHub

It doesn’t make any movement. Can you please show me how the result should be?

You drag the sliders manually. I can add a play function, if that’s what you want.

Which slider? Sorry I’m new in this.

Copy the code I linked above. Paste it into the Macro window and click “Run”. An interface should pop up. If not, you don’t have vanilla installed. Go to Plugin Manager > Add-ons or something (last tab) and install vanilla. Then restart Glyphs.

Vanilla installed already. Am I make a wrong setup or something?

Hmm, thank you. Could you open an issue on GitHub (on the file I linked) with that error code? Then I can fix it. Thank you!

Added. Thank You!