Overlaps not removed in InDesign

In Glyphs 3, I’m suddenly having a problem where my overlaps are showing in InDesign when zoomed out at a certain percentage. They do not export or print this way, and overlaps disappear when zoomed in a bit further, but it it disconcerting to see when working with text. Any insights into this?

That has nothing to do with Glyphs 3. This is one of the rendering modes of InDesign that kicks in at certain PPM sizes. When exporting, make sure to turn on overlap removal for avoiding this situation.

That’s the thing—I have “remove overlaps” turned on when I export.

Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.