Paste Special doesn't include metrics

Hi there, I am trying to copy/paste special a set of characters and their metrics. For some reason the metrics part of it is broken: they aren’t updating. I tried restarting the app and it still didn’t work. I even tried completely clearing the glyphs and ‘paste special’ but it’s still not working, the metrics all just come up as zero.

The first thing that came to my mind was using this useful script by @mekkablue.

Hope that helps!

Do those glyphs contain components? Maybe the automatic component alignment is overwriting your copied values?

No the don’t contain components.

Thank you Ricard, I am aware and I can also use ‘Copy Layer to Layer’ script as well, it’s just that the copy/paste special is very fast as it has a short cut and really SHOULD be working.

Can you send me a screencast of what you are doing exactly?

Sure thing, here you are:



SECOND MASTER METRICS (copied from first master)


I hope I fixed it. But for now, if you only select “Content of active layer”, you should get what you need. The other options are there to only copy those values.

Including the right and lest sidebearings?

The side-bearings are part of the “content”.

Interesting, so why the need for the RSB, Width and LSB options?

As I said, when you only like to copy the side-bearings and not the outlines.

Aha, gotcha. Thank you Georg!