Pasting glyph names for Remove Glyphs custom parameter

It would be nice to be able to paste the glyph names as comma separated values when pasting into the Remove Glyphs value after copying the glyphs or glyph names from the Font view.

In the Font view, if I select the glyphs and then copy with Command-C and paste into the custom parameter value field, the actual characters get copied. If I select the glyphs, then use Copy Glyph Names (from menu after right click or control-click) and then paste, the names (e.g., /A/Aacute…) get copied.

So, for now, I need to copy the glyph names into another file and add commas between each name. Then, paste that back into the value field for the Remove Glyphs custom parameter.

Here’s the situation:

  • Typeface with 1,000+ glyphs.
  • Creating an instance with a small subset of those glyphs.

Or, am I missing something in simplifying this part of the workflow?

Selet dome glyphs in the edit view, right click and select Copy Glyph names. Paste it in a text editor and find and replace the “/” with ", " and copy it into the custom parameter…

That’s what I’ve been doing, though using command-line tools like sed. :slight_smile:

Georg Seifert
I’m trying the same thing,on Glyphs 2, remove some glyphs on different instances, I used comma separated characters, and does not work… is it a beta issue?

In the dialog, you need to put in one glyph name per line, no commas.

A good question though if it should accept comma separated lists as paste. Would facilitate creating such a parameter. I will file a feature request.

Great, thanks, it worked. One new problem, I’m working with a @All class, where I have all my glyphs listed, and I need it for each instance a different set (because some glyphs do not exist in some instances), is there a way to remove the glyphs from a class with something like “remove glyphs”?

I just added an ‘All’ and an ‘AllLetters’ class that is automatically updated (to Glyphs 2).

nice, but when I generate the otf, the class do not update automatically. I should generate instances to separate .glyphs files to make it work properly, right? (loved the automatic @All class, thanks!)

The new, updating classes are available in version 699. And you have to set the automatic checkbox.

I updated and still not working,
this is the message that pops out when I export the instance to OTF.

The class ‘a_alt01’ is not automatically updated. I can’t help you with this one. I only added automatic update for the classes ‘All’ and ‘AllLetters’.

oops. my bad.