Pasting Node Problem

In previous versions when copy and pasting from any program (e.g. FontLab, Illustrator, or any other program) the nodes remain as they are in Glyphs. In the latest build when you perform a copy and paste all nodes get converted to sharp.

Here I am demonstrating the issue on 823 and the latest. You can see that in 823 the nodes remain intact and on the latest all nodes get converted to SHARP.

The core of the problem is that Postscript does not differentiate between these two kinds. As a temporary workaround, you can simply tidy up paths afterwards, with the menu command of the same name.

I mentioned the previous version as reference of an example where it worked as expected. Maybe Georg did some magic behind the hood, but it was gold.
Currently, I am tiding up path as you mentioned, but it is somewhat manual and cumbersome approach.

The magic that happened is the same magic that happens when you press Cmd-Opt-Shift-T. You can do it for all glyphs at once too if you like.

Tidy Up Paths was performing under the hood every time I was copy/pasting something in the previous builds? I didn’t know that.

Anyhow, if this is the case. I would be happy to not perform it myself everytime.

Hey there,

I have Glyphs running on two machines. Funnily on one (895) machine pasting paths results in sharp nodes (just like @Realist describes it) on the other machine (827) the paths attributes are copied from Illustrator.

I tried to adjust the past board settings in illustrator with no effect.

It would be nice to have a consistent workflow so that the same action on two different machines delivers the same results.

The smoothness settings from Illustrator is not in the data in the clip board. So Glyphs needs to guess. You can run ‘Tidy up paths’ to get default smoothness. I check why it is not applied automatically.