Pixelation of a typeface

I am currently working on a monospaced font which I would like to pixelate (next to to the regular, medium, bold & black version in a font family, I would also like to add a pixelated version as well). Does anybody have any experience or suggestions on how to pixelate it?
Any help would be much appreciated.

I have a script for that in my GitHub repository.

thank you so much!

Thinking of which, I guess I should turn this into a plugin, rather than a script.

i hope i will now how to use it :slight_smile:

I have another dumb question. how can I install vanilla?
Because i ran the python script but when i clik insert pixels i get this “Pixelate Error: ‘NoneType’ object is not iterable”

do you know what’s the problem?

The error message does not mean that vanilla is missing.

But to make sure that the libraries are installed, use the plugins pane in the preference.

yes the libraries are installed, but i am still doing something wrong as it gives me the same error.

Iterating over NoneType sounds like an empty glyph selection.
But I do need to update the script for 2.3.

when i have a selected glyph i get this error “Pixelate Error: global name ‘NSPoint’ is not defined”
and the vectorised glyph dissappears…

Just uploaded a new version.

How do you run the script?

I ran it in the macro panel

Try putting the downloaded .py file (or better yet, the whole folder) in your Scripts folder: Script > Open Scripts Folder, then restart Glyphs or reload scripts: Hold down Alt while you choose Script > Reload Scripts. It should then appear in the Script menu.

first thank you for all your help!
When i reload the scripts (i have the pixelate script in the scripts folder), it doesn’t show in the script menu…

Then you did something else wrong. Please follow the installation instructions in the Readme of the repository.

Haha thanks for guiding me patiently through this :smile:
I don’t know what I did wrong before now it showed up in the scripts menu. But, when I tried to ran it I got this

Which version of Glyphs are you running? The scripts are always tested in the latest version, in this case 2.3b (856). You can see the version in Glyphs > About Glyphs.