Placeholder is one character delayed

I have the problem that the placeholder is always one character later, for example:

nn[a]nn -> is shown, but the curser stands |b for example already bofore the b

I go forward with fn + ->
the character shown as placeholder [] is alway one character behind the actual character. This is a bit annoying. In earlier versions of glyphs it worked correctly. How can this problem be solved?

Thanks in advance.

This is a known bug and unfortunately has been around for a while.

Workaround: Quickly move your cursor one letter to the right and immediately back again. This should reset it.

i cannot find my old question concerning this, so i put it here:

if you have strings with placeholders and switch between your masters, your placeholders are always showing the exact opposite master instead of the active master. say your string in the edit tab is:


your cursor is located at the first line, first charachter [a] and the second line has the placeholders (here shown the [a] again. And these are exactly where the problem occurs.

Back in the day, Georg already wrote, that it is a known issue and has to do with some updating of the drawing. Anyhow it is super annoying and since it always shows the exact opposite master, i suppose it might be something solveable?!

thanks in advance