Please test new plugin: Callipers

I’ve tried to do this, but hit a problem: I want to put the window hiding code in willDeactivate, but due to recent changes, willDeactivate is called when I click on the floating window, which of course makes it immediately disappear. I don’t know how to say “deactivated and now using a different tool.”

Related, I would ideally like to be able to set up the start and end points using the current UI, and then be able to show the thicknesses while dragging points around. In other words, I need something that combines the functionality of a tool and a reporter. I’ve heard that in 2.3 this is possible, but I don’t know of any documentation/examples of how to achieve it.

Any ideas from the devs?

We are working on the plugin API quite a bit in the last few days. Check the GlyphsSDK repo for details.

We’ll add code to handle a floating window for tools.

I don’t have that problem with the FloatingWindow. Ill send you a draft, maybe this helps.

Is there a secret how to select the path? Sometimes Callipers does nothing, sometimes very wired results (see image attached). It would be great to get this working, it’s a fantastic plugin!

Do you remember what two segments you selected to get that output? I can’t reproduce it. :frowning:

it happens quite often. Maybe when the contour is complex (overlapping paths)? In the second example (b) it just seems to take the other direction. But I don’t know have to influence this. The first example (e), I don’t know. Same result when I delete the overlaps, or use the same start and ending in character “c”.

Thanks for the examples; I’ll try and take a look.

Callipers is not working with the latest version of Glyphs any more. It’s a pity because I think it is a really useful tool.

Any chance it could be updated? Any hints from @GeorgSeifert or @mekkablue what needs to be changed?
Thanks!

I’ll have a look (probably tomorrow morning). There have been a few API changes which have broken a number of my extensions and so I need to sit down and get them all working again. In the mean time, why haven’t you bought SuperTool? It’s got Callipers functionality built in. :wink:

I just tested it and it seems to work for me. Do you see anything in the console?

Thanks to some fixes from Georg, I have pushed out a new release.

I will also try to get this into the plugins manager.

Now it doens’t work for me anymore. Nothing happens when I draw the lines.

It seems to work if I Option-Drag the lines. There are some display errors (e.g. the colouring does not go away when I switch to a different glyph), though. Seems a bit unstable.

Simon, are you saying that Callipers through SuperTool works more reliably than the stand-alone version?

As you can imagine, the other tools in SuperTool are not relevant for me.

Hi Simon,

I did buy SuperTool, but how to use or activate Callipers functions? It’s not working for me.

Hi Ludwig. If you have a recent version, you should be able to option drag a start (green) and end (red) line to get a visualization of stem thickness. If that doesn’t work, you may not have the latest - shoot me an email and I’ll send you a copy.

I don’t think so; they should be based on the same code, although it’s possible I made changes to one repository but not the other. I will take a look at the code and make sure that the standalone Callipers plugin is up to date.

I have version 1.0. I just sent you an email.

Hi Simon,
In the past I’ve found Callipers quite buggy, but I’m interested to purchase the SuperTool. Is the current version stable?

@SimonC
Callipers and other tools works fine for me!


I’m on latest cutting edge of Glyphs app.

SuperTool should be fine - what were the problems you saw with Callipers in the past? Because they’re using the same code, it may be that if there are problems in Callipers, they’ll be in SuperTool too; but it may also be that I’ve fixed them (in both places!) since you last tried!

Hi Simon,

Just downloaded the plugin but can’t seem to get it to work. I’ve read through the description of how to use it and read through the comments but still no luck. After I drag the first green line it then disappears not allowing me to draw the second red line.

Hope you can help, thanks.