Plugin interaction causing crashes


since a few days I’m having some crashing issues with Glyphs 3 (3.0.3) on BigSur (11.1).
Issue started with Glyphs crashing while creating or deleting new Master or Instances, manually and via the mekkablue-Script “Insert Instances”. Sometimes it worked fine and sometimes it worked after crashing and restarting Glyphs.

While this was an “alright” issue I could work with, my Plugins started causing more issues.
I’m mainly using Speedpunk and Stem Thickness downloaded via the Plugin-Manager. Since one crash the two Plugins can’t be used together. Running Speedpunk alone without any other Plugin installed works fine. Adding Stem Thickness causes Glyphs to crash the moment I try to run Speedpunk. On the other hand I’m able to run multiple Plugins without real issues as long as I don’t have Speedpunk installed.

I haven’t found anything that could help me and tried most of the things I could find related to issues with Plugins. Tried Python 3.9 and the Python from Modules in the Glyphs settings, reinstalling Glyphs, deleting all preferences for Glyphs as well as manually installing the Plugins, but without any success. Have also send it the Crash Reports from a few minutes ago.

So now im lost and don’t really know how to solve this and in need of help! :slight_smile:

Thanks in advance!

I’m working on the plugin crash. The problem right now is that as soon that I start debugging, all plugins do work fine. So I need to find a way to make it crash again.

1 Like

Are you sure you get a crash only with this two plugins? I just fixed a crash with the “Sync Metrics” plugin.

I just tried the “Sync Metrics” plugin together with a few others without issues.
The moment I installed “Speed Punk” from the plugin-manager and restarted Glyphs it crashed again. If I close Glyphs in the glyph-editor after installing “Speed Punk” and restart it, it just immediately crashes without really opening again. The moment I delete the plugin manually everything works.

I’ll try a few more plugins to see if it also crashes.

Heres a list of plugins I just tired without issues:

Bildschirmfoto 2021-02-07 um 18.22.30

Tried a few more plugins as groups. So “Speed Punk” works fine with these plugins:

Bildschirmfoto 2021-02-07 um 18.48.03

But I kept getting crashes if I add these to “Speed Punk”:

Bildschirmfoto 2021-02-07 um 18.46.55

All of these work fine together:

Bildschirmfoto 2021-02-07 um 18.51.00

Adding “Speed Punk” or “Red Arrow” to the last list causes a crash.

I hope this somewhat helps.

I think I found the problem. Most plugins need an update but the this should be working again.


Seems to be working fine now!

Thanks a lot!