Plugins and scripts not working in v2.5

I don’t know what’s happening now, I can’t use any of the plugins I had before. I had some reporter plugins, red arrows etc. and the Reporter Toggler, but it just seems to be gone now. I even went in the plugin manager and reinstalled them, but nothing happens, most are not showing anymore and the ones that are showing are not working. Any idea why this is?

I cannot reproduce it. At least the ones you mention arte compatible with 2.5, and work fine for me. Try reinstalling Glyphs:

Ok that is weird. I did reinstall it, but didn’t change anything. Just tried reinstalling “ShowInterpolation” now also, but doesn’t even show up.

You might need to update the plugins. And also some of the liberties like vanilla. Do you find any error message in the macro window?

I did check for plugin updates, the “ShowInterpolation” needed update, but it didn’t matter. I reinstalled the modules, but that didn’t change anything. I did check the macro window though and I’m getting this message almost all the time or something similar at least:
Traceback (most recent call last):
File “”, line 1, in
File “/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/”, line 24, in
File “/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/”, line 21, in _update
import objc._objc as _objc
AttributeError: ‘module’ object has no attribute ‘_objc’
Traceback (most recent call last):
File “”, line 1, in
NameError: name ‘os’ is not defined
Traceback (most recent call last):
File “New Tab with”, line 7, in
import vanilla
File “/Library/Python/2.7/site-packages/vanilla/”, line 1, in
from vanillaBase import VanillaBaseObject, VanillaBaseControl, VanillaError
File “/Library/Python/2.7/site-packages/vanilla/”, line 1, in
from AppKit import *
File “/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/AppKit/”, line 8, in
import objc
File “/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/”, line 24, in
File “/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/”, line 21, in _update
import objc._objc as _objc
AttributeError: ‘module’ object has no attribute ‘_objc’

Sorry, this seems to be mission < string > on 2 or 3 occasions.

There seems to be something wrong with the python environment. But I got the same report from someone else, too. So it seem not your system that is broken but some thing is breaking it. I have to investigate that.

After updating my OS to High Sierra and even trying to update the Python framwork, nothing seems to work. So I reverted back to this version, and now everything is working fine:

I guess it has something to do with the v2.5, just don’t understand what.

I also have this same issue, and it only popped up once I installed Glyphs 2.5.

Traceback (most recent call last):
  File "<string>", line 3, in <module>
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/", line 24, in <module>
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/", line 21, in _update
    import objc._objc as _objc
AttributeError: 'module' object has no attribute '_objc'
Traceback (most recent call last):
  File "<string>", line 93, in <module>
  File "<string>", line 2, in metricsTest
NameError: global name 'Glyphs' is not defined

Strangely, this only happened on my iMac. The install of Glyphs that I have on my laptop does not have any problems. It is also worth noting that the Beta version of 2.5 did not have any problems on either of my systems.


Which script is this?

I just typed in:
font = Glyphs.font

And the above is what I get.

Did you do this in DrawBot?

Nope! This is the standard Macro panel of Glyphs.

That seems to be a problem with your Python? import objc._objc as _objc shouldn’t fail.

Well, it is. The Macro panel was working fine in the old version, and the beta version. Then I updated to 2.5 and everything started failing. I haven’t touched any of my Python system files at any point in this timeline.

One thing I did just realize, though, is that my desktop machine is on 10.12.6 (Sierra) whereas the laptop is on High Sierra. It could be that there was a change made in Glyphs 2.5 final that broke python functionality on the older OS? I’d be surprised if that were the case, but that’s all I can think of.

Anyway, I’ve needed to update this computer anyway. Might as well test to see if it makes a difference.

I run Glyphs on 10.12.6, also, and have not seen this issue. fyi. I’m running the latest beta 2.5.1 (1140).

The metricsTest in that traceback makes me think there could be a plugin causing those messages, though I don’t know offhand one that has that name in its code somewhere. Or, perhaps there is something that caused it (as suggested and since Georg mentioned a couple other similar reports).

Have you tried starting Glyphs without plugins (shift-option while starting Glyphs, I believe)? Or perhaps re-installing?

1 Like

OK, I managed to get it all working again. I’m still not entirely sure why, but am glad it is functional.

Updating OS had no effect.
Reinstalling Glyphs had no effect.

It appears that the issue was due to an alias in the Plugins folder that pointed to a non-functional Plugin in the Repositories folder. Awkwardly, it is my RotateView plugin—apparently the github version is broken. Will have to investigate. It is still a bit weird, though, as It was working fine before :confused:.

Anyway, sorry for the trouble. I’m still sort of surprised that the error message didn’t mention the name of the plugin in it (the metricsTest item in the error message was the little script I was trying to run at the time, not the offending plugin). Would have made this simpler.

I’m fighting with obscure python problems all the time.

So I have 2 problems now. The old version that I reverted to is getting super slow and laggy, and 2.5 still doesn’t want to recognise my plugins. Would love to update to 2.5 again now, any chance you found out what’s causing the program not to recognise the plugins?

What plugins do you mean?