Plugins Crashing & No Python Version

Hi all, I’ve been trying to get word-o-mat and speedpunk plugins to work for a while now but they keep crashing on launch. I’ve installed all the modules through the plugin manager however I cannot verify the python version as advised by the install instructions of the python module. Any clues? how do I fix this? I’ve already tried reinstalling glyphs and reinstalling plugins and modules countless times. Thanks in advance.

Here are some screenshots that may help (I can’t upload more than one image on the forum):

What version of Glyphs and macOS do you have?

Glyphs 3 Version: 3.0.4 (3108)
MacOS Monterey 12.3

Please update to the latest cutting edge version. Activate it in Preferences > Updates > Show cutting edge versions.

I’m still getting the crash notification, so I just tried reinstalling the python module after updating but I’m getting this error now.

Screen Shot 2022-04-05 at 7.11.32 pm

The python module is installed now and I can see the Python Version displaying as “3.9.1 (Glyphs)” but the plugins are still crashing.

Reinstalling the plugins has fixed it. Both plugins are now working. Thank you @GeorgSeifert