Plugins won't work on Glyphs 3

I tried to install 3 plugins from the Plugin Manager (Show Top & Bottom, Show Stem Thickness & Show Kerning Values) and none of them work, and also they make Glyphs crash. The message I receive is in the image above.

1 Like

The plugins should work on Glyphs 3 but there seems to be a problem with the new MacOS Big Sur. We’ll look into it.

2 Likes

I tried and those plugin work fine for me. What version of python do you have?
you can out this in the macro window and post the result:

import sys
print(sys.version)

I am on Big Sur, too, and plugins in Glyphs 3 cause the same crash as pictured above. Entering the Python code in the Macro window results in this:

I also tried to install the Python 3 runtime from the plugin manager. Plugins and the code above still lead to a crash.

how did you install python?
can you run this in the terminal?

pip3 install pyobjc

Hi, It says “zsh: command not found: pip3 install pyobjc”. (Sorry I’m so bad at these).

pip3 install pyobjc did run successfully, but Glyphs is still not starting with a plugin. I installed python3 with Homebrew (non M1).

This is my current Python setup:

~ python3 --version
Python 3.9.0
~ pip3 --version
pip 20.2.4 from /usr/local/lib/python3.9/site-packages/pip (python 3.9)
~ pip3 list
Package                                           Version
------------------------------------------------- -------
pip                                               20.2.4
pyobjc                                            6.2.2
pyobjc-core                                       6.2.2
pyobjc-framework-Accounts                         6.2.2
pyobjc-framework-AddressBook                      6.2.2
pyobjc-framework-AdSupport                        6.2.2
pyobjc-framework-AppleScriptKit                   6.2.2
pyobjc-framework-AppleScriptObjC                  6.2.2
pyobjc-framework-ApplicationServices              6.2.2
pyobjc-framework-AuthenticationServices           6.2.2
pyobjc-framework-AutomaticAssessmentConfiguration 6.2.2
pyobjc-framework-Automator                        6.2.2
pyobjc-framework-AVFoundation                     6.2.2
pyobjc-framework-AVKit                            6.2.2
pyobjc-framework-BusinessChat                     6.2.2
pyobjc-framework-CalendarStore                    6.2.2
pyobjc-framework-CFNetwork                        6.2.2
pyobjc-framework-CloudKit                         6.2.2
pyobjc-framework-Cocoa                            6.2.2
pyobjc-framework-Collaboration                    6.2.2
pyobjc-framework-ColorSync                        6.2.2
pyobjc-framework-Contacts                         6.2.2
pyobjc-framework-ContactsUI                       6.2.2
pyobjc-framework-CoreAudio                        6.2.2
pyobjc-framework-CoreAudioKit                     6.2.2
pyobjc-framework-CoreBluetooth                    6.2.2
pyobjc-framework-CoreData                         6.2.2
pyobjc-framework-CoreHaptics                      6.2.2
pyobjc-framework-CoreLocation                     6.2.2
pyobjc-framework-CoreMedia                        6.2.2
pyobjc-framework-CoreMediaIO                      6.2.2
pyobjc-framework-CoreML                           6.2.2
pyobjc-framework-CoreMotion                       6.2.2
pyobjc-framework-CoreServices                     6.2.2
pyobjc-framework-CoreSpotlight                    6.2.2
pyobjc-framework-CoreText                         6.2.2
pyobjc-framework-CoreWLAN                         6.2.2
pyobjc-framework-CryptoTokenKit                   6.2.2
pyobjc-framework-DeviceCheck                      6.2.2
pyobjc-framework-DictionaryServices               6.2.2
pyobjc-framework-DiscRecording                    6.2.2
pyobjc-framework-DiscRecordingUI                  6.2.2
pyobjc-framework-DiskArbitration                  6.2.2
pyobjc-framework-DVDPlayback                      6.2.2
pyobjc-framework-EventKit                         6.2.2
pyobjc-framework-ExceptionHandling                6.2.2
pyobjc-framework-ExecutionPolicy                  6.2.2
pyobjc-framework-ExternalAccessory                6.2.2
pyobjc-framework-FileProvider                     6.2.2
pyobjc-framework-FileProviderUI                   6.2.2
pyobjc-framework-FinderSync                       6.2.2
pyobjc-framework-FSEvents                         6.2.2
pyobjc-framework-GameCenter                       6.2.2
pyobjc-framework-GameController                   6.2.2
pyobjc-framework-GameKit                          6.2.2
pyobjc-framework-GameplayKit                      6.2.2
pyobjc-framework-ImageCaptureCore                 6.2.2
pyobjc-framework-IMServicePlugIn                  6.2.2
pyobjc-framework-InputMethodKit                   6.2.2
pyobjc-framework-InstallerPlugins                 6.2.2
pyobjc-framework-InstantMessage                   6.2.2
pyobjc-framework-Intents                          6.2.2
pyobjc-framework-IOSurface                        6.2.2
pyobjc-framework-iTunesLibrary                    6.2.2
pyobjc-framework-LatentSemanticMapping            6.2.2
pyobjc-framework-LaunchServices                   6.2.2
pyobjc-framework-libdispatch                      6.2.2
pyobjc-framework-LinkPresentation                 6.2.2
pyobjc-framework-LocalAuthentication              6.2.2
pyobjc-framework-MapKit                           6.2.2
pyobjc-framework-MediaAccessibility               6.2.2
pyobjc-framework-MediaLibrary                     6.2.2
pyobjc-framework-MediaPlayer                      6.2.2
pyobjc-framework-MediaToolbox                     6.2.2
pyobjc-framework-Metal                            6.2.2
pyobjc-framework-MetalKit                         6.2.2
pyobjc-framework-ModelIO                          6.2.2
pyobjc-framework-MultipeerConnectivity            6.2.2
pyobjc-framework-NaturalLanguage                  6.2.2
pyobjc-framework-NetFS                            6.2.2
pyobjc-framework-Network                          6.2.2
pyobjc-framework-NetworkExtension                 6.2.2
pyobjc-framework-NotificationCenter               6.2.2
pyobjc-framework-OpenDirectory                    6.2.2
pyobjc-framework-OSAKit                           6.2.2
pyobjc-framework-OSLog                            6.2.2
pyobjc-framework-PencilKit                        6.2.2
pyobjc-framework-Photos                           6.2.2
pyobjc-framework-PhotosUI                         6.2.2
pyobjc-framework-PreferencePanes                  6.2.2
pyobjc-framework-PushKit                          6.2.2
pyobjc-framework-Quartz                           6.2.2
pyobjc-framework-QuickLookThumbnailing            6.2.2
pyobjc-framework-SafariServices                   6.2.2
pyobjc-framework-SceneKit                         6.2.2
pyobjc-framework-ScreenSaver                      6.2.2
pyobjc-framework-ScriptingBridge                  6.2.2
pyobjc-framework-SearchKit                        6.2.2
pyobjc-framework-Security                         6.2.2
pyobjc-framework-SecurityFoundation               6.2.2
pyobjc-framework-SecurityInterface                6.2.2
pyobjc-framework-ServiceManagement                6.2.2
pyobjc-framework-Social                           6.2.2
pyobjc-framework-SoundAnalysis                    6.2.2
pyobjc-framework-Speech                           6.2.2
pyobjc-framework-SpriteKit                        6.2.2
pyobjc-framework-StoreKit                         6.2.2
pyobjc-framework-SyncServices                     6.2.2
pyobjc-framework-SystemConfiguration              6.2.2
pyobjc-framework-SystemExtensions                 6.2.2
pyobjc-framework-UserNotifications                6.2.2
pyobjc-framework-VideoSubscriberAccount           6.2.2
pyobjc-framework-VideoToolbox                     6.2.2
pyobjc-framework-Vision                           6.2.2
pyobjc-framework-WebKit                           6.2.2
setuptools                                        50.3.2
TBB                                               0.1
wheel                                             0.35.1

1 Like

Having the same problem here: it crashed when I clicked on “show unicode” in the preferences panel and it won’t reopen. I’ve restarted the mac and installed back Glyphs3 with no success. I’m on Big Sur as well

Try entering one of the following two lines in the Terminal and launch Glyphs 3 again (I am not sure whether the option is on or off by default. Try the first line, if it does not work try the second.):

Show Unicode:

defaults write com.GeorgSeifert.Glyphs3 GSFontViewShowUnicode -bool true

Hide Unicode:

defaults write com.GeorgSeifert.Glyphs3 GSFontViewShowUnicode -bool false

If non of the two lines above work try deleting the value:

defaults delete com.GeorgSeifert.Glyphs3 GSFontViewShowUnicode
1 Like

We need to update all the plugins, again. ;(

2 Likes

Thanks for the reply, Florian! Unfortunately, none of the above mentioned solutions worked :frowning:

Ah, that is painful. Maybe start with a simple plugin (like ShowNodeIndexes) and let’s test whether that already does the trick. Just so that not all plugins get updated and then there is still something missing.

1 Like

Hm, in that case I suspect that the “Show Unicode” checkbox is not the culprit. Open ~/Library/Application Support/Glyphs 3/ and delete the following directories (if they exist).

  • Plugins
  • Repositories
  • Scripts

This is problem with the plugins in Big Sur and python 3.9. I’ll update the plugins, asap.

3 Likes

Thanks Florian and Georg!
Yes, I deleted the plugins after trying out your code and now it works. I’ll wait for the Plugin update to switch to Glyphs3 :slight_smile:


I changed the Python version to 3.8.2 and it worked well again!

1 Like

@GeorgSeifert image is there anyway to show all the masters on the toolbar like Glyphs 2? Currently they’re hidden in this panel and it’s quite inconvenient to select masters.

When there’s not enough space to show all the masters, they’re moved to that menu. If you’re able to widen the window, it’s possible the master icons may reappear, then. It’s also possible to switch between the first 9 masters with Command-1 through Command-9.

1 Like