Preview Interpolation


Something strange is happening with the preview area. I’m not sure if it’s a bug or not.

I’m working with 4 masters. Normally the preview area showed me the interpolation between “Thin” and “Regular” always, even if I had nothing in the master “Black”. Now, it seems to work randomly.

For example, on this image, I have those 4 glyphs compatible on 3 masters. I have nothing on the “black” master, but Glyphs just gives me the interpolation on the number 1 and 4. Sometimes Glyphs gives me the 4 numbers, but when I save the document, 1, 2 or 4 (random) glyphs disappear from the preview area (instance). Or sometimes, I’m working on glyph “2”. I move 1 point to the left ou right, and that’s enough to the preview area show the interpolation or not.

It forces me to add something compatible to the black master. (a copy from the thin master for example)

When I generate instances, they seem to interpolate properly.

Any help?

I recorded a small video to explain it. (1.4 MB)


Can you send me the .glyphs file?

Yes. I will email it to you support [at] …

Thanks @GeorgSeifert

Found a temporary solution: I have to change something on the glyph while pressing space bar (preview), otherwise it stops the interpolation. I can’t save before export. Very very strange! Check the video. (2.7 MB)

I hope you can find a solution. It’s quite annoying.

I have fixed it. Thanks for the file.

1 Like

@GeorgSeifert, I download the update, but the interpolation bug remains. Let me know if you want the file again.

I fixed it after uploading the latest update. Stay tuned.

1 Like

Thanks :+1: