Problem when exporting very small circles

When exporting very small circles or removing the overlap on very small circles, the output is weird. The circles aren’t being drawn correctly on the otf file.

To reproduce this:

  1. Create a new file
  2. Set grid spacing and subdivision to 0
  3. draw a circle of height and width of both 2
  4. apply ‘Remove Overlap’ on circle

I get this:

Bug also occurs for circles of height and width of 3, but not of 4.

Can you help me understand? I tried it on a friend’s computer who has Glyphs Mini and bug still occurs.

This is a problem with the clean up code. The curves are so small that they are removed. I will try to improve this.

But what do you need so small circles?

I am designing a typeface with a lot of weights and styles. I am only having this problem for the lightest weight when working on the rounded styles (the ends of the stems are rounded off in perfect circle).

I will try other “tricks” to work around the problem and will let you know.

Does it happen with other curvatures as well? Try Fit Curve with 60% on the round ends.

I just tried and unfortunately that doesn't work. The problem is not so much the filter or tool that's used but how Glyphs exports these very small curves.

Try this: go to File > Font Info > Other Settings, set the Grid Step to 0, and export again.

There is some code that removes very fine details in the remove overlap filter. Handle length less then 1 unit where considered to short and thous removed.
I lowered the threshold to keep your circles. I will publish an update later this week.

Thank you very much. I will keep an eye out for the update on the Mac App Store.

Then perhaps upscaling and downscaling with a custom parameter could work. You draw the light with a higher UPM, and then scale to a UPM of 1000 at export time.

I don’t want to play with the UPM value. Mine is set to 128 on purpose and it needs to stay that way. Thanks for your input though.

Sorry, I did not make my point clear, it seems. The UPM value can stay the same in the final file. No one said it would change. With the parameters, you can upscale, remove overlaps, and downscale again, in that order. Same file as before, just with the curves intact. The trick is that the removing of overlaps is done in the parameter, and not (!) in the export options.

So essentially, I’d be drawing a large circle and scaling it down?
I don’t think it will help my cause since the circles appears fine in Glyphs before I apply the ‘Remove overlap’ filter. It’s just once I export it that the current version removes the curves - but as Georg mentioned, the update is being pushed so I’m not too worried.


  1. Keep your drawing as it is.
  2. Add three parameters in the instance:
  • scale to UPM: e.g. 1280
  • filter: GlyphsFilterRemoveOverlap;
  • scale to UPM: 128
  1. Export, but WITHOUT the option Remove Overlap.

Actually, just deactivating ‘Remove Overlap’ in the export settings solves it!
Thank you. I just have to double check the letterforms in InDesign now.

But of course it still leaves extra anchor points in the font file…

Could you post a screenshot on how to do this? Sorry I'm a bit of a newbie when it comes to custom parameters.

I tried it. And it doesn’t work :frowning:

When is the update coming for Glyphs Mini Georg? I see it’s the same version available on the Mac App Store.

I am sorry, the workflow I described requires the Pro version of Glyphs. What do you need a UPM of 128 for?

My entire typeface family is based on a 128 units square grid.

I did get it to work in Glyphs mini:

  1. Font Info (cmd-i): Set the Grid Step to 0.
  2. With the Palette (cmd-opt-P)), scale up all glyphs by 100%
  3. Filter > Round Corner with twice the radius.
  4. With the Palette (cmd-opt-P)), scale down all glyphs by 100%.

It’s better but it creates a slight mis-match when I compare it to the other fonts in the family. The curves are accurately preserved but the baseline is off by a few units.

Black: where the letterform should it
Green: where it is actually sitting