Problem with autohinting

I keep getting an error message when trying to export my font:
"There was a problem autohinting the glyph: m
Please hint this glyph manually."
When I delete the m, it reports the n. When I delete both, I can export just fine. This is the first time this has occured, and all I did between the last export and this, was to transform the letters by -1.5 degree. I do not have overlaying paths, and I added extremes to make sure that is not a problem. Neither of these actions helped. What can I do to fix this?

Can you send me the .glyphs file. One way to deal with it is to manually add hits in the glyphs that it complains about.

Try correcting path direction and tidying up paths, then try again.

Hi Georg, Hi Erich, I sent the file. But cleaning up the paths for the m helped, I did not even need to change the n. Fixing the m lets me export it just fine. Thanks for the help.

Already happened with me, sometimes just exporting again solve the problem. =P

Sometimes, cleaning out the Temp folder helps, too.

Have the same Problem here:
There was a problem autohinting the glyph: tildecomb.i
Please hint this glyph manually.
(tmp folder was empty)

could localize the problem in the “Black Italic” (weight:183)
a subsetted glphs-file with the problematic letters is attached: Harrisson italic (12.4 KB)

Also getting this error:

I’ve tried all the above, but wish to solve this without setting manual hints… any other ideas?

Can you send me the file?

Ran into the same issue with tcedilla for one instance (all other instances export fine). Tried the suggestions above but still won’t let me export, and I’d prefer not to manually hint that one glyph. Thoughts?


You can exclude that glyph from autohinting with the Disable autohinting for glyphs parameter in the respective instance. Or you can tweak the glyph a little until the autohinter can handle it.

Thanks, will try those options…

…the parameter for that one glyph worked. The instance now exports. I suppose it won’t be much of a discernible difference that one glyph isn’t auto hinted.

To further comfort you: if everything works well,m this glyph should not even appear at all. More info in the Romanian tutorial.

Appreciate the further comfort, that’s good to note :slight_smile: