Problem with interpolation arabic

I have a problem with interpolation,
all glyphs are compatible and no problem but when i test the font i see the glyphs overlapping instead of connecting according to the anchors as you can see in the shots below
what could be causing this?

i’m interpolating from regular & Bold

Have you checked your first point position?

That seems to be a strange incompatibility. Could you send me the file to support at this domain (maybe delete all other glyphs then the one in the string)?

Over the email you recommending making the layers icons “eyes” off
that didnt work
I’m updated now to Version 2.3b (860) and the problem is still there

as i export the font i noticed a problem with connecting anchors for some letters in interpolated weights
now is this problem will be solved?
is there a way to test arabic interpolated weights while on Glyphs to test and fix?

Can you move the cursor one letter to the left and send a screenshot?

hope this is what you needed

Hello Again Georg
the problem is “solved” if i keep the direction of type from left to right -the icon in the right lower corner
hope that can help figuring out why is it happening

The Bold Layer still has an open eye in the layer panel. Close it and it will work. I’ll fix it, soon.