Problem With Plugins & Modules

Can anyone help me out on plugin installations? When I click on ‘Install Modules’ and nothing happens… spinning beach ball… that’s it. I’ve done the obligatory quit, restart, reinstall… License is properly installed…

Also, there’s no ‘Plugins’ button.

When it stops spinning, the modules are installed.

Which versions of the app and system are you running? Have you tried re-downloading?

It doesn’t install the plugins, just the dependencies.

I’m using the latest version.

FYI - I reinstalled with the same results. Then reinstalled again, and the problem went away.

Suggested improvement: when the python modules have been installed either the ‘Install Modules’ button should be inactive or a message should alert the user that the modules are already installed.

Users just need some feedback letting them know the status of the module install.


The ‘install module’ button is going away and the functionality will be moved into the Plugin Manager.

Hi to all, I’m new on Glyphs, and I’m not very expert.
I too have the same problem in preferences addons.
The interface don’t change after press button and insert it password.
Nothing indicate that modules are available, and the button no go away.
I’ve tried to reinstall the latest version of app many times, and license is properly installed.
How do I know if the modules are installed correctly?
Many thanks for your help.

There is no feedback in the window. All that happens is that you should see the ‘spinning beach ball’ icon for a few seconds. When your cursor goes back to normal, the modules are installed.

Copy and paste this into your Macro Window:

import vanilla

Then press the Run button. Do you get an error message written in red? Then it is not installed. Do you get the vanilla docs printed (in black type) in the Macro Window? Then it is installed.

1 Like

All is installed correctly, I’ve found also the folder in Python with the packages.
Thank you very much for your help.

1 Like