Problem with Turkish i and Tcedilla/Scedilla localisation

Neither in Glyphs nor as a font Turkish i and subbing T/t, S/scedilla by T/t, S/s commaaccent don’t work properly. Turkish i only works for Azeri (not for Crimean Tatar, Kazakh, Tatar, Turkish). Subbing T/t, S/scedilla by T/t, S/s commaaccent only work for Romanian (not for Moldavian)

Tested the font in many software like FontGoggles,, Adobe apps, Affinity apps

I’ve read the tutorials over and over, couldn’t find the mistake.

There is a small issue with the way language specific opentype feature are compiles right now. It is fixed and should work in the next update.


For now, you can disable automation and write it like this:

script latn;
language AZE;
lookup locl_TRK {
	sub i by idotaccent;
} locl_TRK;
language CRT;
lookup locl_TRK;
language KAZ;
lookup locl_TRK;
language TAT;
lookup locl_TRK;
language TRK;
lookup locl_TRK;

I.e., put the substitution in a lookup, move the script declaration and the first language declaration in front of it, and call the lookup with the different languages afterwards.

1 Like

Alright. Thank you