Problems applying Filter: RoundCorners Custom Parameter to type master

I am working to create a font similar to Cooper Black, where all corners (inside and out) are rounded. I would also like to draw my type with overlaps, so I have good control over shapes and interpolation. This means that I need a way to automatically round inner corners after/during exports.

It seems that adding a Custom Parameter of “Round Corners” is the proper way to do this, but so far the methods I have tried do not seem to work. Am I missing something?

Here’s my master:

Here’s a simple view of what I would like to achieve on export:

Methods I have tried are:

Thanks for any clues to how I might achieve this!

Have you considered doing the Round Corners before export?

Filter > Round Corners from the Menu bar.

1 Like

Thanks for the reply! I’ve told you before, but I love Glyphs, and I don’t think I’ve recommended any design software more times.

Sorry, I might not have been very clear in my question. I am trying to draw glyphs with overlapping shapes, so I can properly draw the “stoke” of the letterforms and edit it as needed throughout my process. Then, during export – and only after the overlap is removed – do I want corners to be rounded.

So, for instance…

The above shape is easy to work with, because the right side can be easily edited, by moving just a single point. Therefore, it’s much more efficient to edit than…

…this version, which has rounded inner corners before exporting, but requires a lot more fuss to edit. Additionally, I worry that this version might be more of a pain to A) keep consistent and B) prep for interpolation, because it requires more individual points, where my human error could cause more issues.

So, the Filter:RoundCorners in font info does seem like the right solution, but I am just having trouble making it work how I expect. I’m not sure if the problem is because of the shapes I am working with or whether I’m using incorrect syntax. Based on the examples I’ve found so far, the syntax seems to have maybe changed over time. Do you know what the current syntax might be?

I appreciate any further advice!

if you use negative corner radiuses in the filter it will apply it to inner corners.

@George_Thomas: the whole point of the filters it that you don’t need to apply it before you export. That is important for interpolation as the filter might change the node count and interpolating the small curves will result in a lot kinks.


@GeorgSeifert Thanks, yeah that’s a smart feature! I did see that in the manual, and I am trying to use it that way.

Am I doing this correctly, in using the GlyphsFilterRoundCorner; -35; 1 syntax, where -35 is the radius, and 1 sets optical corrections to true?

I’ve also tried copying in from the “Round Corners” filter, as recommended in this tutorial, but it does not seem to work either after export. It unexpectedly puts something like JSON into the field, also, which is not what I expect to go in Custom Parameters (though, I’m not sure what is correct or incorrect).

In all of the ways I have so far tried to export with the custom parameter set, the exported result of the glyph built with overlapping shapes is still this:

The same happens on the basic rectangle, as shown in my first post on this thread – I wanted to do a test whether the glyph shape made a difference.

As you may be noticing, this is an Arabic script face, but I’m not sure whether the unicode value for these glyphs should affect the way Custom Parameter filters work. I suppose I should also test whether things are working on a basic Latin glyph…

OH. Found my error. Facepalm.

I was putting the filter into the incorrect place.

It needs to go into the “Instances” tab in the Font Info; I was mistakenly putting it into the “Masters” tab.

For the record, the current correct syntax (from my initial test, at least) seems to be GlyphsFilterRoundCorner; -35; 1.

Thanks for helping me troubleshoot this! Hope my dumb mistake helps someone else. :smiley:

Wonderful, yup! The exported font is rounding beautifully, from overlapping forms in the master.

Great feature! I’ll be sure to share the tip with my classmates, in case they want to do this in the future. :slight_smile:

You can use a shorter filter title: RoundCorner; -35; 1

1 Like