Problems on 10.13.6

I tested the beta up to version 3028 and had no bugs or other kinds of problems. Today I bought a license and now I have some weird behavior on version 3032 when I try to enter the Text-Mode by pressing “T”. When I do that, two things happen:

  1. all words (or rather all characters in general) become invisible
  2. I can’t write/add anything

What I already tried:

  1. I tried an external Keyboard, but then I realized that I can write anywhere except in the editing field. I thought it might be a problem due to old version files, but even if I create a new file, I still have the same problem.
  2. I tried to reset the appearance settings to standard, after that I changed the settings so that the light mode is always used (because I thought I might be a problem with High Sierra since this macOS version has no darkmode).

Also tried to reinstall the app, but nothing changed.

We has the same report before. Can you post a screenshot of the toolbar? And one from your Plugin folder (you can find it be clicking “Open Scripts Folder” in the Scripts menu).


I’m on 10.13.6, G3 and don’t see that happening here.

What tool shows up when you press and hold the Text tool in the toolbar?

Only “Text” and “Extrude”.

And when I select “Extrude” and change to another tool after that, it doesn’t even respond anymore when I press T?

I believe the Extrude plugin needs to be updated before it can be used in Glyphs 3. For now, uninstalling the plugin may likely fix that issue.

you were right, I uninstalled the extruder tool and now everything works fine again, thank you!