Problems with corners / working with open paths

I’m drawing a typeface in open paths and using the custom parameters filter to add a stroke weight when exporting.

I’m having issues with the corners. When having a closed corner, the resulting drawing (after export) is sometimes a very sharp corner. I have found out that this issue is solved when breaking the path. But when exporting this, the resulting drawing (after exporting with a stroke value) show two single strokes converging to the same point and not a corner.

I have uploaded reference images here.

Do you know a solution that could help me solve this issue with corners and get a clean, straight corner in the resulting font?


how should it look? can you manually tweak it and upload a screenshot?

Here it goes, it is marked with blue on the B

Thanks. I will see what I can do.

Martina: what exactly is the difference in the pink corner? I mean between the last two pictures.

Hi Mekka,
In this case there’s no difference. That is the result when I break the corner. The blue corner is actually the issue, where the path is not broken and I get a super sharp corner. Would be great to have a straight corner as shown.

So, what you want is a miter limit?

Is that how it’s called??? Yes! :slight_smile:

Hey guys,

I’d love a quick tutorial on how to set up a stroke font… and the exporting using the custom parameters Martina was referring to.
Or can you point me to where can I read about it in the manual?


I’d still want to learn more about this. How to set up your font to do this:

I tried adding the glyphsfilteroffsetcurve but I’m missing something because it’s not working.

Maybe a 1,2,3 step simple tip from you guys will make my day!

The filters are case sensitive. Click on the purple question mark and scroll down to the filter section. There you can copy paste the correct syntax.

Georg: That purple question mark has never worked for me. I always get “The selected topic is currently unavailable.” in the Help pop-up window.

Including the latest beta 1.4.3b1 (555) on OS X 10.8.2.


If the question mark does not work, you have a really old version if Glyphs laying around somewhere. After deleting it, it should work eventually.

I ended up removing the helpviewer’s Cache.db:

Thanks for the trigger to look into it in more detail. It works, now.

I’ve used the correct case sensitive filter and it’s not working… but I also don’t know the full workflow. What else I should set up.

Would love a small tutorial on this. Or somebody to share what else you have to set up for open path fonts…

This is quite a big deal for me as I’m more into scripts…
Thank you

Can you select the line you put in the custom parameter, copy (cmd+C) and paste it into the forum?

So, surprise, today worked to insert the code:
GlyphsFilterOffsetCurve; 20; 30; 1; 0.66;

I have no idea how to use this :slight_smile:
I’ve drawn a couple of lines to test it but nothing happens on export.
Am I the only one not figuring out how to use this?
Sorry to be such a pain…

Thanks for your time Georg
I was trying to replicate what you did on that post.

Can you select the whole line, not the text and press cmd+c.