Problems with Glyphs 2.4.4 in High Sierra

Is there any problems with running Glyphs on High Sierra?
Because Undo got removed.

Best Regards, Carolina

This has nothing do do with the operating system. This is mostly caused by a plugin. Can you remember hat plugin or filter you used before the undo breaks. It is most likely several operating earlier.

Yes. I run »Change metrics by percentage» by MekkaBlue. But it was 3 days ago.

Hmmm. That would be a script, not a plugin.

I got DrawBot and Retractor in Repositories. (I have not plugin in supertool yet). Is there any of those you might think causes the problem. It is hard to work in Glyphs today. It does not respond on simple commands, such as undo, mark a node etc etc

You cannot select a node?

Is it fixed in the latest beta? (You can keep stable version and beta next to each other in the Applications folder.)

Hmm. That’s right. I do have a problem with selecting a node. Or deselect. it is between zooming and using selection tool. What’s the latest beta version called?
Thank you!

I also have a problem with Glyphs in High Sierra.
I’m using a simple script to make all selected nodes first and Glyphs (2.4 or 2.5) crashes almost every time. The script worked without problems before.

I reinstalled Glyphs and it is working much better.
Glyphs still responds very slow, when I do select a note, it takes a few seconds to respond, but it does respond.
I will continue to work on High Sierra. The update was not supposed to change so much in the enviroment for the apps according to Apple.
Best, Carolina

1 Like

Are you sending the crash reports?
Some changes in the API are normal. You may need to adapt the code.

OK, Version 2.5b (1086) on High Sierra 10.13.1 (17B48) seems to be working fine for me. We already scheduled for a screensharing session, will take a look then.