Problems with removing overlap and compiling features

Hello, for some time I’ve been experiencing a problem with Remove Overlap. It just stopped working some time ago. No matter if it’s from the Filters menu or when exporting. It always says “Something went wrong with the Remove Overlap filter in glyph:…” I even tried reinstalling the app and it doesn’t work.

The other problem is when I generate and compile features I get a message “There was a problem converting the PostScript source font. (temp)”

As a result I cannot remove overlaps automatically, export the font at all and see if the features work. I’d be grateful for advices.


Which app version?

Version 2.6.1 (1230)

Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

And empty out the Temp folder maybe.

Worked! Thanks!! Such a relief ;))

1 Like

Same problem here. Remove overlap filter does not work neither in the menu nor at exporting. Glyphs Version 2.6.2 (1264) running in an iMac with 10.9.5. Emptied the Temp folder with no results.

Interestingly when the same file was opened with the same version of Glyphs in a laptop running 10.13.6 it worked perfectly.

Any clue what I should look at in my old iMac?

Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.

The problem comes up in any file I open. I sent you a small file and some screen shots so that you can make your tests.


  1. open
  2. clear the contents of the window (there’s a button in the toolbar that does it)
  3. Type “Glyphs” in the search field
  4. Go to Glyphs and try to remove overlap
  5. Switch back to Console and see if there are error messages.

Attached you will find the report I got in the console.

Thank you. (3.7 KB)

Okay thanks, this is very helpful.