Python install problem (with restart issue)

First sorry for bad Eng

my Mac is M2, ver 13.5

I try to install python, but it doesn’t work
I tried Script-Python runtime install
and then I restarted glyphs but it doesn’t work…
so I tried to check python version,
but at preference, something is wrong

that means,
‘You changed python version, so you have to restart glyphs app.’

Idk what can I do now
please help me

Most likely, you restarted too quickly and the installation was only partially done.
Remove it in the plugin manager and then reinstall it there.

I removed plugin manager but it doenn’t work (same error)
also I removed glyphs but same situation…
how can I remove all of glyphs data? I tried to remove all of data but it doesn’t work

I am having the same issue on M2. Tried deleting and reinstalling from plugin manager, deleted Glyphs app a bunch of times, hunted down all the files in Application support, Caches, Preferences folders but nothing works, after reinstalling it seems like I still could not remove all the data.

1 Like

Ahh… I think it’s M2’s problem.
if you can check this problem, please answer to us.
I have to do my work so I have to solve problem rapidly T.T

To narrow down the cause you should create a new MacOS user account, and then try to install Glyphs and it’s Python from that account. If that works then it is an issue with your configuration, and you should look extra carefully at your .gitconfig in your $HOME. I seem to remember that Glyphs is using this config, and that eg. remapping HTTPS to SSH will break to Glyphs plugin system.

1 Like

It’s working again, I think I was missing a couple of files in Preferences before, something like this com.GeorgSeifert.Glyphs3.plist.

The steps I took were:

  1. Uninstalled Glyphs
  2. Made sure I deleted everything from Library folders (Application Support, Caches, Preferences)
  3. Updated my IOS (not sure that had anything to do with the issue though)
  4. Reinstalled Glyphs and Python module

Before, GlyphsPythonPlugin folder in repositories were always empty even if Glyphs showed it was installed, not this time luckily. Hope this helps you too.

You probably only need to remove the GlyphsPythonPlugin from the Repositories subfolder and try again. Give it more time, or watch the folder while you’re waiting for the installation to finish.