Question about crashing Glyphs because calt

I’m trying to detect the first glyph in a line of text with calt

But every time I activate code with a line like
ignore sub @all @all’;
ignore sub [a_series b_series c_series] [A B C a b c]’;
Glyphs is crashing. Is there something wrong with my thoughts about ignore-rules?

The class all contains:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z a b c d e f g h i j k l m n o p q r s t u v w x y z space path1 path1used path2 path2used animation1 animation2 animation3

while the only code in the calt (for now) is:
#Determine the pattern, starting with the first glyph.
lookup start{
ignore sub [a_series b_series c_series] [A B C a b c];
sub [A a] by a_series;
sub [B b] by b_series;
sub [C c] by c_series;

(the code was larger, but I have reduced it to this into Glyphs itself to look into this trouble…
When looking at the Adobe knowledge center, I can’t see any possible cause.


There are no marked sub runs. The tick marks are missing. Take a look at for code examples.

On a side note, a_series is probably not a good glyph name. The underscore is for ligatures. Did you mean a.series?

Sigh, you are right.
I really have to get more sleep. The code I posted is not the best one of all I tried. But that missing tick mark wasn’t the trouble. It was responsible for some of my experiments to not work, but it wasn’t responsible for the crashes I saw.

With the class @letter =
a b c d e f g h i j k l m n o p q r s t u v w x y z A B C D E F G H I J K L M N O P Q R S T U V W X Y Z Astart Bstart Cstart

lookup SeriesStart{
ignore sub @letter @letter’;
sub a’ by Astart;
sub b’ by Bstart;
sub c’ by Cstart;

It seems to work.
But when I change the code to:

lookup SeriesStart{
ignore sub @letter @letter’;
sub a by Astart;
sub b by Bstart;
sub c by Cstart;

Glyphs can’t even compile, it runs forever.
Same story when I change the code to:

lookup SeriesStart{
ignore sub @letter @letter’;
sub [a A]’ by Astart;
sub [b B]’ by Bstart;
sub [c C]’ by Cstart;

It works, but when removing the tick marks:

lookup SeriesStart{
ignore sub @letter @letter’;
sub [a A] by Astart;
sub [b B] by Bstart;
sub [c C] by Cstart;

Glyphs crashes while activating the calt-feature in an example.

can you send me the .glyphs file?

Done @ support

I have tested further on an other Mac.
It crashes on OS X 10.7 and OS X 10.9,
both latest version of Glyphs, 1.4.3.

Haven’t tried 1.4.3, but it does not crash with 1.4.4. Enable: Glyphs > Preferences > Updates > Cutting Edge Versions, and then check for updates.

Is 1.4.4 online already?
I am checking for updates since a couple of days, but it says 1.4.3 is the latest version. (cutting edge versions enabled).

Really? Cutting edge should give you the 1.4.4 beta. Perhaps it could not complete the install. Perhaps take a look in the Application Support folder.

I’ve deleted the Glyphs folder in Application Support
and the com.GeorgSeifert.Glyphs.plist in the preferences.

even then I get this message saying 1.4.3 is the latest version:

And I am admin on my Mac. Something else I can do?

The update feed ( only contains version 1.4.3. The items for the beta are commented out. This has to be fixed on the server. Nothing to do on your side.
Changelog also dosen’t show any beta infos anymore BTW…

I now have 1.4.4 (602)
This build also crashes when the tick marks in line 3, 4, 5 are removed.

ps; when removing the lookup, everything is also fine. (this is the only code for now.

lookup test{
ignore sub @letter @letter’;
sub [a A] by Astart;
sub [b B] by Bstart;
sub [c C] by Cstart;

I can’t reproduce this. Can you send me the .glyphs file?

It is the same file as previous week. Here it crashed on 2 Mac’s. Is there something else I can test to see if the fault is on my computer?

I just tried you file and it works fine. Can you try the latest version?

I could reproduce it eventually. It crashes when you pick calt from the Features pop-up in an Edit tab. I sent a crash report (“Maarten-calt-Crash” in the comment).

Of cause.
The problem is that if you mix different lookup types (in this case one line that has tick marks and the others don’t) in a lookup declaration makeOTF generates invalid lookup data instead of abborting with an error. I will fix the crash.

Thanks for looking into it, for the explanation and for fixing it :slight_smile: