Questions about GlyphDate.xml use

I thought the User GlyphData.xml was supposed to override the app copy; apparently it doesn’t, or I’m doing something wrong.

I entered this so I could add acute to the accents for Cyrillic Ze-cy:

The problem I encounter is that it does not add the Zeacute-cy to the Cyrillic script section, rather puts it in Other.

  1. Is this because this character does not currently have a Unicode value?

  2. If I instead add it to the PUA so it has a Unicode value, will that force it into the Cyrillic script section?

If I add this to my custom GlyphData.xml, it works just fine. The hole file has to look like this:



and be saved into ~/Library/Application Support/Glyphs/Info/GlyphData.xml

or you call the glyph Ze_acute-cy.

or don’t add the glyph at all and use the mark positioning to build the glyph.
you should add this to the ccmp feature:

sub acute by acutecomb;

then in Indesign or Word, you type the Ze-cy and an acute an the acute will jump in place…

Part of the problem was solved by the fact that my path was going to X_Info, not Info. Fixed that and now at least I can make a composite using Cmd-Opt-Shift-C.

However, it did put the new character cell into its own separate “Letter, cyrillic” section. Is that because it has no Unicode value, or because it is outside of your built-in encoding?

can you select the glyph and run Font > update glyph info?

Yes, and it now appears in the correct section, although not in the order I would expect (I have “Keep alts next to base…” turned on).

The order is Zeacute.cy, Zhe-cy, Ze-cy. I expected it to follow Ze-cy.

Then you need to add a sortname to the glyph definition

OK, I will do that. Is there an example in the master file?

[Edit] Never mind; I checked the file and found it.

Thanks.

Any guidance on what would make a good sortName for this glyph? I tried several and only succeeded in pushing it to the end of the Cyrillic Uppercase section (without a sortName). I kept working on it and ultimately got it back to where it was originally (zeacute-cy, zhe-cy, ze-cy).

I just checked and the cyrillic uses a slightly different sorting algorithm and does not support the sort names. I will fix that.

Thanks Georg. Lack of support for sortName might explain some of the bizarre things that happened while I was trying to make it work.