Re-interpolate broken


#1

In the current cutting edge 2.5b (1093) version the re-interpolate function between compatible outlines no longer works. Tested on three different Glyphs files with three masters each.


#2

already been noted


#3

That should be fixed now.


#4

Hi Georg! I’ve tried both in 2.4.4 (1075) and the latest cutting edge version (2.5b 1101) and can’t seem to get “re-interpolate” to work. It simply generates an empty glyph (with roughly the right width). I’ve read a few threads about this being broken and fixed so I’m wondering if I’m doing something wrong.

I’ve got two masters (Bold and Light) and they’re compatible (for the letter, some other parts aren’t). They’re generating instances in the preview.

I’m trying to fix that little overlap by just redrawing the glyph (which I expect to be fairly simple if I can get the generated version on the layer!). There’s only one width (100) and I’m only interpolating the weight. I’ve created a layer called Intermediate {75,100}. Clicking re-interpolate on it whether there’s something on the layer or not results in an empty glyphs in both versions.

Am I doing something wrong? I’ve toyed with created a new thread but figured I should just re-use this one for ease for searchability.


#5

can you send me the file?


#6

Of course! Sent it to support@, let me know if I can do anything else.


#7

@GeorgSeifert I continued investigating, turns out I have an extra master (Regular) that I’ve disabled with the “disable masters” property on the instances. That master is an old work in progress I keep as reference but it seems that re-interpolate still tries to use that master (possibly rightly, as I don’t see an option to deactivate the master globally). The preview does ignore the Regular master (respecting the custom property) and I suppose I expected re-interpolate to do the same. Is there a way to tell re-interpolate to ignore a master? Or to disable a master globally but keep the drawings?