Re-interpolate bug

I’ve imported a regular instance into my xlight>bold file for final edits. The instance comes with a bunch of brace layers that I will still want to tweak. Now if I delete a brace layer and the contents of the Regular layer and re-interpolate all contents are removed and the width is set to 0. If I delete the contents of a Regular layer without brace and re-interpolate it works fine. I guess I can go back and wipe unnecessary brace layers but this seems like a bug.

What exactly are you reinterpolating? The Regular layer or a brace layer? And why do you delete layer contents? If you are breaking compatibility, it cannot be reinterpolated.

The Regular layer. For /e/ the brace layer regular{a,b} was deleted and the regular emptied and it would not re-interpolate the regular between Light and Bold masters. On glyphs without a brace layer if I emptied the Regular layer and re-interpolated it would do it. Basically behaviour is different when it should be the same.

I find adjusting values in the brace layers can be quite a helpful process tool. I’d like to still be able to do this in the 3-master file.

Either way, even if I delete all the brace layers from this file I can’t re-interpolate those glyphs if I make edits either side of regular.

I cannot reproduce this. I tried this:

  1. Created three masters Light at Weight 10, Regular at Weight 100, Bold at Weight 500.
  2. In a glyph, drew different but compatible shapes in the master layers.
  3. Added a Brace layer {300} with a different compatible shape.
  4. Made sure the drawings were compatible, had instances placed with the Insert Instances script.
  5. Removed the Brace layer from step 3.
  6. Re-interpolated Regular.

Works as expected for me in Version 2.4.1 (976), I tried with and without emptying the Regular layer first.

Why do you empty the Regular if you are going to re-interpolate it anyway?

A two-axis brace layer in a single-axis setup?

Hey Rainer —

Thanks for taking the time to look into this.

I tried this also. No problems. The only thing I did differently was:

— Started with a two-master file.
— Generated the regular instance
— Imported that as an intermediary master

From this point on all behaviour was as described. However, if I save, close the file and re-open it it works as expected! It seems that layer data when it comes to re-interpolation is not updated with a new ‘live’ master.

On a separate note (already a super feature) – is there a reason one can’t select multiple glyphs to re-interpolate in batch?

Thanks again for your help!


Just making it crystal clear nothing is being added.

Good question! :blush: