Red triangles and metrics warnings

What does it mean when a glyph has a red triangle in the upper left corner? My guess is that it means that it is impossible to interpolate that glyph (because I haven’t drawn it in every master yet or the outlines don’t match); is that right?

Also, many of my glyphs have a :warning: sign, indicating that the metrics need to be updated — but when I select any of them and press control-command-M to update metrics, nothing happens. Do these signs indicate that anything is going wrong, and is there a way I can get rid of them?

For reference, here are the glyphs that have that hard-to-remove warning — it seems kind of random:
Æ Ð G J K Ľ M Ŋ Ơ Œ Þ R Ư V W X æ b c d i j k ľ ŋ ơ œ p q ß ư w y Δ Ω μ 0 6 ! ⸘ $ € ∅ ∞ √ @ ¶ © ®

The red corner means, as you have guessed that the outlines are not compatibl. And you need to update the metrics for all masters to get rid of the yellow triangle.

Okay, thank you!

Hey there. I’ve got red triangles too. Could you please explain what “not compatible” means ?
If I chose “Update metrics”, it doesn’t remove those triangles…

This tutorial has some information.

"Our job is simply to make sure that all masters have the same number and order of nodes and handles, as well as the same number and order of paths. Also keep in mind that it is very important to have the same set of anchors in every master. "

Ok thanks @Cormullion.
I misunderstood the use of masters…
My goal is to create a “shadow” style for my font as in this capture.
I thought masters would be the way to do it, but it’s not !
So what would you recommend ?
I duplicate the Glyphs file to work on a seperate set of characters ?

Not sure but I found this.

Thanks @Cormullion but it is precisely the tutorial I used to start with my shadow style…
But a shadow can’t have the same number of nodes that the glyph, so I think Masters aren’t the right way to create shadow style…

In Glyphs 3, masters are checked for compatibility by default. You can add a “Enforce Compatibility Check” custom parameter to disable that check.

Thanks @GeorgSeifert.
So Creating shadow style using Masters could be a good idea :smiley:
But I can’t find the “Enforce compatibility check” in the custom parameters list…
The pop-up window becomes empty when I type “enforce”

In the Font tab, add a Custom Parameter Enforce Compatibility Check and then deselect the box which appears next to it. It applies to the entire font.

OK thank you @George_Thomas !
I thought it was a Master custom parameter…
So now I added this parameter and unchecked it, but I still can’t see both masters when I click on the eye icon of the layer palette… Is it normal ?

Are you in Font View or a glyph window? The other Master(s) selected only show in the background of a glyph window.

I am in the glyph window as you can see :

You have the Text tool selected; change it to the Select tool. Select the eye on the other layer to see it’s paths.

Look closer at the video, the problem is the same with both tools selected : the video starts when the the text tool is selected, and after that I change it to the Select tool.

Once you are in the Select tool, the paths on the other layer show.

Do you want to select paths across layers? Switch to the Select All Layers tool. It hides behind the main Select tool.

I see. I tried that with one of mine (just a normal font with three Masters) and that does not happen so I don’t know the answer. @Georg or @mekkablue needs to answer it.

The incompatible masters mean, in plain english, that your paths have different amount of anchor points or paths directions are different or the first nodes are different between masters.

In case of your “shadow font” the paths do not need to be compatible because there is no interpolation between masters. To figure why you are getting red arrows it would be great if you could share your font info screenshots for both masters tab and instances tab. Have you added instances by “add instance for each master”?

Thank @elenan but since I’ve did what Georg had suggested (add an Enforce Compatibility Check parameter) there is no more red triangles ! :smiley: