Remove Overlap Error and Glyphs 3 Crashing

I added a width axis to a font with 2 weights. When I tried to export it had a remove overlap error with Æ and then R and then P. I was unable to get it to export even when I removed the wide width from instances. Then it crashed. Now Glyphs won’t even open it just crashes as soon as it loads. I sent a report with my email and name on it several minutes ago.

What version of Glyphs do you have?

Can you open the app with the Option and Shift keys pressed to disable the loading of plugins.

Hi Georg, yes I am open that way. Currently running 3.0.3

Now it’s saying ‘Something went wrong when Removing Overlap in glyph:’

I wish it would just give me a list of all the glyphs with issues instead of going one by one. Or give me the option to not export the affected glyphs like Glyphs 2 did (I think.)

Can you try updating to the latest cutting edge version? (Activate it in Preferences > Update).

And can you send me the file that I can have a look at that overlap problems?

It says its on the most up-to-date version available

With cutting edge releases active, you should be on 3.0.4.

Will the plugins work with this one or do I still need to open without them?

Ah, I answered my own question. It still doesn’t open. Which plugin is causing Glyphs to crash upon opening?

That is a tricky question. To find the culprit, remove the first half of the plugins (Open the Plugin Folder and move them out into another folder). Then start Glyphs. If it works now, the problematic one is on that removed group. So remove the other half and put the first half back. Remove half on the plugins until it still crashes and you have narrowed it down.

Okay, I wasn’t sure if there was some known ones that aren’t working with Glyphs.