"Remove-overlap"-filter doesn't work

Since I have installed the latest version of Glyphs (1.4.4 Beta 8a (601)) the “Remove-overlap”-filter doesn’t work anymore (“Something went wrong…”).

Same here…

Fixed it. Please update.

Using most current version on your site, 1.4.3. and getting “Remove-overlap”-filter doesn’t work alert when I try to export. How do I get access to the fixed copy? (I updated the software but the issue persists.)

Please activate “show cutting edge versions” in preferences.