Remove Overlap Filter

So I made a simple font last year just to get some frequently used icons together for myself and it all went smoothly. Today, I tried to add one more icon and now I’m getting the “Something went wrong with the remove Overlap filter” error when I try to export. I tried removing the single character that I added and the problem persists. Then I went down the rabbit-hole of posts on this forum with similar problems and couldn’t find a solution that worked for me.
I’m using version 1.4.5 (614) on macOS Catalina version 10.15.7
My font only has 16 characters with me trying to add a 17th and the shapes are all pretty simple. If I try to export without the remove overlap filter, I get an unknown “MakeOTF error”.

Can you try the latest cutting edge version (activate it in Preferences > Update)? And if that still produced the error, could you send me the .glyphs file?

With both boxes checked, it still tells me that I’m up-to-date when I click to Check Now. I’ve attached the glyphs file.
RFGIcons.glyphs (42.9 KB)

What version of Glyphs do you have?

Version 1.4.5 (614)

I tried it in that version and it works fine for me.

I guess I’ll have to try more troubleshooting from my end, then. Thanks for checking!
For now, though, could you send me the .otf file that you were able to export? (3.2 KB)