Rename glyph parameter not honoring anchors of renamed glyph

I am having an issue with the rename glyph parameter. I have a.alt=a where a.alt is a double-story ‘a’ that replaces a single story ‘a’. This successfully replaces the glyph along with all component glyphs for other languages (a godsend by the way). The issue is that while the glyph replaces correctly the anchors seem to be from the original glyph causing misaligned diacritics.

Must be an issue with an update to Glyphs app. I opened up an old file that hasn’t been touched in months and did a test export. Sure enough the renamed glyphs are now misaligned.

Should I roll back to an older version of Glyphs for now? Time is of the essence as I am prepping my font files to upload to for release this coming week.

Please advise. Thanks in advance!

This issue still persists (in this case, with exactly the same scenario). Any news?

I just tried it in 3.1.1 and it seems to work. Can you send me your file to see why it does work for you?

How is it supposed to be used? Maybe I used the parameter wrongly.

I have adireresis, aogonek, etc. in my font, but in the custom parameter I only added the line a=a.ss01, but not adieresis=adieresis.ss01 etc.

Is this a problem?

Edit: Yes, apparently this is a problem. If I add the line aogonek=aogonek.ss01, the anchors (and spacing) get used correctly. This is only slightly annoying, as it means I have to write every a (and not forget a single one). But it’s okay overall :wink:

It did work with only the replaced base glyph for me.

I verified again and get the same issue. Could it have something to do with the fact that my a.ss01 is made up of components?

Edit: No. Composite or decomposed a.ss01 doesn’t make a difference.

I will try to prepare a file to send you.

I am going mad, I have no idea where the issue could lie. Deleting some glyphs seemed to make it work. Then I tried to narrow down the glyphs to the problematic one, but ended up deleting every single one and it still wasn’t working.

I sent you a mail with a few more details and two files.

Restarting Glyphs has something to do with it, apparently, but in the opposite sense – a file where it works doesn’t work anymore after restarting Glyphs.

Good luck!