Renaming private use glyphs

Hi got a weird thing going on when I try to rename a private use glyph after assigning a unicode value. First couple I tried it didn’t have an issue when I renamed but now whenever I try to rename a glyph it loses it’s unicode value and hops into the ‘Other’ section.

Any help? Is this a bug or am I missing something?

What is the name you are trying to apply? Perhaps it is defined in the Glyph Data already. You can check in Window > Glyph Info.

I even tried things like test and random letters but it always loses the unicode value

Before changing the name, check the ‘use custom Naming’ in font info > other strings.

I can’t see that option in info… I still don’t get why it worked the first two times then stopped

Am I missing something obvious?

Didn’t see that you have Mini. The option is only available in the full version.

I have a look.

Thanks, as I say I managed to get the first couple to change name but then all of a sudden It just stopped keeping the unicode value

Did you get a chance to look at this? As I said, i’ve managed to rename glyphs in the past but seems to have stopped working.

Didn’t had time. But could you give some examples of what unicode you had used and then names you liked to assign?

I managed to get uniE000 and uniE001 to change names to home and location, but every increment after that hasn’t allowed me to rename. Examples of names

  • Globe
  • Phone
  • Graph
  • Camera
  • Search
  • Play
  • Car

Too bad, I will purchase full Glyphs when I will get graduated this year.

I fixed it.

For a future update?

That should work in the latest cutting edge version of the full version. I update Mini, soon.

Thanks Georg