Reopen closed Macro Panel Tab

Is there a way to reopen an accidentally closed macro panel tab, or at least the content?

Not yet, unfortunately. Sorry.

Good to know, though. Thanks!
Usually I don’t keep important stuff in there, but I had so much on my plate and just realized I destroyed some long piece of code the second after i clicked that big ol ‘×’ :man_facepalming:

Sometimes, for some reason, all Macro panel tabs except for the one last used disappear.

I just re-opened Glyphs only to find my 7 previous Macro panel tabs gone, with some scripts I was using (and modifying) all the time. I know I should have kept them in some safer place, basically, I just came here to complain. Please ignore.

With a TimeMachine backup, you can perhaps restore the app prefs. They are stored in there.

Same happened to me.
I like the idea. Where do I find these app prefs? Or do you mean I should the whole glyphs app restore

The preferences of the app are written to the file located at

~/Library/Preferences/com.GeorgSeifert.Glyphs3.plist

where ~ is your user directory. Do not edit this file directly. However, if you have backups of your system (for example, Time Machine), then you can restore this file (do not overwrite the existing file) and look for the macro code in there. The macro code is listed under the key GSMacroViews.

To open the file, you need an app that can open binary property list files, like Xcode or TextMate.

1 Like

Okay… I have it restored from the timemachine, and I opened it with textmate.
(I’ve put the restored file to a temporary folder)

But I dont know where can i find the GSMacroViews.
(I’ve restored these file as well)
Képernyőfotó 2023-07-04 - 17.00.41

Press Control-S and search for the key.

Well perhaps I’m too new for this part… but CNTRL+S… doesn’t seem to help.

With TextMate open, you should be able to search within the file with Control-S. Otherwise, use EditFindIncremental Search.

there are two Preference files. One in ~/Library/Preferences/com.GeorgSeifert.Glyphs3.plist and one in a ByHost folder. You need the former.
It should look like this:

1 Like

My fault… I used the wrong file… sorry.
I’ve fixed it, and I got my old macros.
Thanks

2 Likes