Resolving glyph name and encoding conflicts

I have a family of fonts which have been exported from FontLab to Glyphs, and have since been extended quite a bit. Now upon trying to generate instances I’ve learned that when Glyphs imported the fonts, it encoded some glyphs as per the GlyphData.xml which were unencoded in the FontLab file. So now I have both commaaccent and uni0326 mapped to u+0326. I need both glyphs, but I only want uni0326 encoded to u+0326. How do I un-encode the commaaccent? I want to keep the names as they are for compatibility with a previous delivery to a customer? I don’t want to have to make a custom GlyphData.xml just for this family.

If it is just this font family, go to File > Font Info > Other Settings and disable Nice Names there. Then, you can set your own names and Unicode values.