RLIG not working

sub lam-ar.init alef-ar.fina by lam_alef-ar;

this code is not working in my font.

I have checked and rechecked everything.
language system entry for arabic is there.
all init medi and fina forms for lam and alef are there.
all anchors are set.
the features are generated automatically.

Please help thanks.

Are init and fina features ordered before rlig?


I just tried moving the rlig above init and fina, and it still does not work.

Where are you testing. Rlig is not widely supported. When I remember correctly it is not supported in Adobe apps.

I’m testing in glyphs.

Do I need to duplicate the features to liga?

The preview in Glyphs is not 100% OpenType conform. Proper testing should be done in a web browser and Indesign.

It must come after init/isol/fina/medi, since it makes use of .fina and .init forms.

And you can test it in Adobe apps with the World-Ready Composer.

I exported the file as OTF and tested on Windows 7, Indesign 2018 (with world ready composer) and the font is behaving oddly.
Only the letters in “Basic Shapes” category are being displayed correctly, all the other shapes (all letters under “Basic”, init, medi and fina) are being completely ignored.

I added customParameters of “unicode ranges” in font info.

In InDesign, all marks are “fatha, damma, kasra etc.” are also not showing.
and entry and exit anchors are also not working.

I tried the font in MS Word 2010 and everything is working just right.


In the World Ready Composer, you need to set the language to Arabic as well. Then the positional substitutions are triggered.

Perhaps make sure your glyphs have correct Unicode values: In Font Info > Other Settings, disable the Custom Names setting. Then, select all glyphs in Font view and choose Glyph > Update Glyph Info.

Current version is CC2019. How exactly are you testing in InDesign? Are you using the Adobe Fonts folder?

I experienced a similar problem when opening and updating an Arabic glyph file to Glyph app 2.6.5 (1342).
As a result, the ‘Lam_alef-ar’ ligature does not work (after updating the OT features).
If I remove the part of the lookup script, then it works.

Actual rlig feature script:


After removing part of the script (manually):


I have tried to remove the feature and update OT again. I do not know what’s happening . Everything looks fine.
Any idea?

Thanks a lot, in advance.

Tested in Adobe InDesign English-Arabic version

I mean, is that piece of script really necessary? I assume that it is necessary since it is generated automatically when updating rlig feature. But, as I exposed before it does not work.

Only when I remove part of that script, it is working fine. But, I wonder if is it ok or am I missing something important. Thanks.

What do you have in “LanguageSystems”?

Hello Georg,
The problem was in the Language systems script. I just noticed it. Thanks a lot for your advice.
It seems to be solved now.