[RMX] Error, Glyphs Version 2.5b (1082) on macOS 10.12.6


#1

Tuner, Scaler and Monospacer don’t work at all (Harmonizer works fine):
Problem mit Filter: RMX Scaler -[GSFontMaster weight]: unrecognized selector sent to instance 0x6000003a0460

Is it a problem of my file?
Glyphs Version 2.5b (1082) on macOS 10.12.6


Rmx tools broken now
#2

same here…


#3

Probably a result of the new master setup in the files. I got the same.


#4

This is do to a change in the Glyphs API. I have a look.


#5

Hi Georg,
Do you have news about this?
Thanks,
et


#6

I believe @TimAhrens is aware of the issue and working on an update.


#7

Yes, working on an update. Will let you know as soon as possible.


#8

great!!


#9

To fix the error mentioned above, please update to version 1.1 of RMX for Glyphs.

If you have purchased the full version, use this link:
https://remix-tools.com/glyphsapp/update/full

Don’t forget to restart Glyphs after updating the plug-in!

There are many other small changes and improvements in this version so it is worth updating in any case. I will write up a list of changes with detailed explanations, and update the manual shortly.


#10

just updated, thanks for jumping on this.
thanks tim


#11

I had no problems before, saw the thread and thought that it would be nice to have the latest update of RMX Tools anyway. Installed the update with Glyphs 2.4.2 running and immediately had the same Error as FAlthausen when using RMX Scaler. I then tried to update Glyphs to 2.5b (1086) to see if the error still occurs. It still does. How could I fix it now, if I already have the RMX Tools updated? Thanks in advance

correction
It’s a different error. See screenshot:


#12

@TimAhrens
Works right for me, thanks!
Version 2.5b (1086) / MacOs Sierra 10.12.4


#13

Sorry about this. Coud you send me a description and, ideally, a .glyphs file by e-mail?
Thanks!


#14

Thanks for the report, Tobias. Looks like this only occurred with German language setting. I had to completely deactivate the German localisation to avoid the error. The new update (version 1.1.1) fixes the error.


#15

Thanks Tim. That did the job!


#16

@TimAhrens
since I updated RMX to 1.1.1, scaler crashes every time on some glyphs.


#17

Could you send me the .glyphs file? Maybe just with a couple of glyphs in it? Thanks!


#18

file sent


#19

Thanks for the file. The bug is fixed in the latest RMX version (v 1.1.2).


#20

I’ve just noticed, that when I use the tuner for slanting, the value applied to the glyph would be double of what I enter in the respective field. @TimAhrens can you reproduce that?

Version 2.5b (1092), RMX 1.1.1