RMX for Glyphs 3

It worked when I dragged it. Thanks!

I had RMX installed & working in Glyphs. It has now has disappeared completely from the Filter menu. I have tried reinstalling/override previously installed — nothing. It does not appear anywhere in PlugIn Manager (either in ‘All’ or ‘Installed’) but it does show up in the GlyphsApp Plugins folder. Please help. Thanks.

Make sure you have the latest version. There was update just recently. And double click it to install, then answer the dialogs presented to you.

The last time I installed it I had to move it. Double-clicking results in it trying to install in G2.

I have the latest version of Glyphs 2 (2.6.6). I installed RMX for Glyphs 2. I’m upgrading to 3 soon as I get my coupon code — I wasn’t sent one AFAIK. I was using a trial version of RMX till recently. This seemed to cause a lot of problems when initially installing – didn’t seem to want to override it. Can’t remember exactly what I did but I got RMX working after half an hour’s trial and error. All features worked with 2 masters etc. Then it just disappeared!

Sorry to hear you are having problems. Can I recommend to fix it like this:

  • Using cmd+shift+Y, open the plugins folder and remove RMX.glyphsfilter as well as RMXdemo.glyphsFilter if present.

  • Note: you have to do the above for Glyphs 2 and Glyphs 3 independently as they both have their own plugins folder.

  • Close Glyphs.

  • Then drag the right RMX.glyphsfilter (or RMXdemo.glyphsFilter) file onto the corresponding Glyphs icon on the doc, as I wrote several times above. Don’t double-click (cc @mekkablue) as it would not give you control over which Glyphs version will open the file. You will not even be able to tell which Glyphs version has just opened it in case both Glyphs versions are running (i.e. have a dot on the dock).

  • Restart Glyphs (btw @GeorgSeifert why isn’t this enforced by Glyphs? I belive I have requested this many times before).

Also, @GeorgSeifert, the current RMX version (1.1.8) has the Info.plist entries for MaxGlyphsVersion and MinGlyphsVersion, as you suggested. Why is Glyphs ignoring them? Glyphs 2 should reject to install RMX for Glyhps 3 and vice versa. If Glyphs looked at these entries during (or before) installation then we could save a lot of the users’ confusion, as becomes obvious in this thread.

1 Like

Thanks Tim. I’ve upgraded to Glyphs 3 & it’s all working perfectly now.

Hi @TimAhrens,

I have no idea if this is the better place but I have problems with RMX (1.1.7 and 1.1.8) in Glyphs 2 (2.6.6 1350) in MBP with Big Sur (11.1).

When I try to use it the app crashed and the problem persists for a week. I tried to remove RMX and reinstall again but didn’t work.


Could you send me the the crash report and/or the .glyphs file? Thanks!

I fixed a crash that happens when there are two identical masters.
To download the latest RMX version (1.1.9), go to https://remix-tools.com/glyphsapp/update/full (or, for the demo version: https://remix-tools.com/glyphsapp/try).

@BarryBianco I hope this also fixes the problem you encountered. If not then please let me know.

I installed it successfully, but Glyphs 3 still wants me to update it:

I get this too

Oops, sorry. Looks like the new updater is not mature yet. Will fix it. At least “Skip this version” is working, right?

1 Like

Sorry, I was very busy yesterday. The problem persist, at least with RMX Scaler. Where can I send you the files?

Please send them to tim@[the RMX domain] (ideally including the crash report). Thanks!

1 Like

Thanks for the file, @BarryBianco. I just fixed the crash.


Works perfectly! Thanks!

Hi there!

I know this thread is a bit older, but just wanted to check whether there is already a stable RMX version for Glyphs 3 running on the new M1 MacBook Pro?

I get the following message when trying to install it:

“The bundle “RMX” couldn’t be loaded because it doesn’t contain a version for the current architecture.”

Thank you, Tobias

Hi Tobias, which versions are you using?

Support for the M1 Mac was added in RMX v. 1.1.11 (on January 18). Maybe you can just try updating to the latest version? Font Remix Tools update

If the latest version does not work, and you still get the error message then please let me know.

Hi Tim!

Thanks for your prompt reply.

I’ve just updated to 1.1.13. Now it seems to be working. Sorry for the confusion. :slight_smile:

Thanks again, Tobias

1 Like